PAC: URL doesn't work (download problem from compreg.dat)

RESOLVED DUPLICATE of bug 174941

Status

()

Core
Networking
--
major
RESOLVED DUPLICATE of bug 174941
15 years ago
15 years ago

People

(Reporter: David M. Summer, Assigned: dougt)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910

Converted from 1.1 to 1.2a. The proxy configuration is set to use automatic
proxy configuration off of corporate network. Unable to resolve any addresses.

Manually configured proxy and works fine. Other browsers (i. e. Internet
Explorer) work fine.

Reproducible: Always

Steps to Reproduce:
1.Click on auto config and unable to resolve addresses
2.Manually configure & works fine
3.

Actual Results:  
Able to resolve addresses after manually configuring proxy.

Expected Results:  
Should have used URL to configure proxy and resolved addresses.

Comment 1

15 years ago
I see this too.  Win NT 4.0 SP5, Mozilla rv 1.2b build 2002101612

I am on a VPN, and attempting to use auto conf URL.  Manual conf works.
Auto conf on netscape 4.5 works.

If I type the URL of the proxy.pac file into the browser, I get an error:

  "D:\TEMP\v9rciwjr. could not be saved, becuase the source file could not be 
   read.  Try again later, or contact the server administrator"

I got a similar error message when I tried to download the 1.4.1 java runtime 
environment from the Sun site.

Maybe when downloading files to temp locations the browser attempts to use the 
temp name on the request to the server?

Comment 2

15 years ago
I see this bug in Mozilla 1.2.1, 1.3a, and Phoenix 0.5, and the Phoenix nightly
release as of 17 Jan 2003.

My LAN uses a proxy auto config file, which is set in all local web browsers.
For a while it wasn't even being requested, so I knew it was broken, but
recently it has been requested from the web server but ignored.

This auto config file conforms to the spec, and works in Netscape Communicator
4.7x, previous versions of Mozilla, and Internet Explorer (5.0 through 6.1)

Manual configuration of the proxy works as expected.

Comment 3

15 years ago
Could one of the people experiencing this state the exect URL being used? Is it
a file:/// URL, or just a Windows filepath?

WFM using a file:/// URL in Phoenix 0.5, build 20030120, and Mozilla 1.3b, build
20030121 on Windows 2000.

Comment 4

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

Using standard MS ISA 2000 SP1 automatic configuration script URL:

http://<myisaserver>:8080/array.dll?Get.Routing.Script

When I type the URL into the browser it downloads the script with MIME 
application/x-ns-proxy-autoconfig just fine.


Comment 5

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030123

Same problem.

Comment 6

15 years ago
The URL being used on my lan is exactly as follows;

http://zeus.home.lan/proxy.pac

The server (Zeus) serves the auto-config file, MIME type
application/x-ns-proxy-autoconfig, from an Apache 1.3.27 server (it has been
served from this server since Apache v1.3.19 or thereabouts).

The file is locally accessable to the browsers; when I enter the URL in
Phoenix's  (or Mozilla's) address bar I get a "Save As" dialog. When I save, the
entire contents are intact.

For the record, this problem exists in the Linux and Windows versions of these
browsers.

Comment 7

15 years ago
This, bug ##100022, and bug #188006 all appear to be dupes, or at least related
to bug #83984.  Since #100022 has the most votes and the best description, I'll
add my vote there in the hopes that it will do some good.  This bug will force
my corporation to go to IE if it's not fixed soon!

Updated

15 years ago
Flags: blocking1.3b+

Comment 8

15 years ago
blocking+ is set by drivers. you need a good reason to set blocking? and you
didn't even provide that. nor is this bug confirmed.
Assignee: ben → dougt
Component: Preferences → Networking
Flags: blocking1.3b+
QA Contact: sairuh → benc

Comment 9

15 years ago
David and Jeff's problem relate to the compreg.dat regression.

I'm duping this to close that off.

Stewart, James, Roman, and Ray (did I miss anyone?) you might have different
problems. Please file a new bug for each case, so we can isolate the problem.

Please start the summary w/ "PAC:", set the qa to pacqa@mail.packetgram.com.

Make sure you include the PAC URL in your prefs, and attach the file if you can.

*** This bug has been marked as a duplicate of 174941 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
QA Contact: benc → pacqa
Resolution: --- → DUPLICATE
Summary: Preferences/Proxy:/Automatic proxy configuration URL doesn't work → PAC: URL doesn't work (download problem from compreg.dat)
You need to log in before you can comment on or make changes to this bug.