apprunner crashes when I press the "Mozilla" button.

VERIFIED DUPLICATE of bug 15946

Status

SeaMonkey
General
P3
critical
VERIFIED DUPLICATE of bug 15946
19 years ago
13 years ago

People

(Reporter: Mo DeJong, Assigned: leger)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
I was using a cvs build from Fri Nov 5 on a RedHat 5.2 system
when I got this crash.


Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkWidget'
Segmentation fault


Inside widget/src/gtk/nsWidget.cpp


I pressed the little "Mozilla" button in the middle of the bottom of
the screen and got a SIGSEV. The SIGSEV happens on line 1800 because
the rollupWidget gets set to NULL because NULL is returned by the
GTK_WIDGET() call.



1784	/* virtual */ void
1785	nsWidget::OnButtonPressSignal(GdkEventButton * aGdkButtonEvent)
1786	{
1787	  nsMouseEvent event;
1788	  PRUint32 eventType = 0;
1789
1790	#if defined(DEBUG_pavlov) || defined(DEBUG_akkana)
1791	  printf("button press\n");
1792	#endif
1793
1794	  if (gRollupWidget && gRollupListener)
1795	  {
1796	    GtkWidget *rollupWidget =
GTK_WIDGET(gRollupWidget->GetNativeData(NS_NATIVE_WIDGET));
1797
1798	    gint x, y;
1799	    gint w, h;
1800	    gdk_window_get_origin(rollupWidget->window, &x, &y);
1801
1802	    gdk_window_get_size(rollupWidget->window, &w, &h);
1803
1804
1805	    if (!(aGdkButtonEvent->x_root > x &&
1806	          aGdkButtonEvent->x_root < x + w &&
1807	          aGdkButtonEvent->y_root > y &&
1808	          aGdkButtonEvent->y_root < y + h))
1809	    {
1810	      gRollupListener->Rollup();
1811	      printf("rolling up\n");
1812	      return;
1813	    }
1814	  }





Here is the stack trace.


(gdb) bt
#0  0x404b4416 in nsWidget::OnButtonPressSignal (this=0x82a64b0,
aGdkButtonEvent=0x81021c0) at ../../../../widget/src/gtk/nsWidget.cpp:1800
#1  0x404b53b2 in nsWidget::ButtonPressSignal (aWidget=0x82a66d8,
aGdkButtonEvent=0x81021c0, aData=0x82a64b0) at
../../../../widget/src/gtk/nsWidget.cpp:2330
#2  0x405c8a99 in gtk_marshal_BOOL__POINTER (object=0x82a66d8, func=0x404b52d4
<nsWidget::ButtonPressSignal(_GtkWidget *, _GdkEventButton *, void *)>,
func_data=0x82a64b0, args=0xbffff380) at gtkmarshal.c:30
#3  0x4058dc52 in gtk_handlers_run (handlers=0x8123608, signal=0xbffff33c,
object=0x82a66d8, params=0xbffff380, after=0) at gtksignal.c:1909
#4  0x4058d158 in gtk_signal_real_emit (object=0x82a66d8, signal_id=20,
params=0xbffff380) at gtksignal.c:1469
#5  0x4058b468 in gtk_signal_emit (object=0x82a66d8, signal_id=20) at
gtksignal.c:552
#6  0x405c0110 in gtk_widget_event (widget=0x82a66d8, event=0x81021c0) at
gtkwidget.c:2790
#7  0x4056013d in gtk_propagate_event (widget=0x82a66d8, event=0x81021c0) at
gtkmain.c:1296
#8  0x4055f472 in gtk_main_do_event (event=0x81021c0) at gtkmain.c:753
#9  0x40604ed6 in gdk_event_dispatch (source_data=0x0, current_time=0xbffff700,
user_data=0x0) at gdkevents.c:2098
#10 0x4062dc8f in g_main_dispatch (current_time=0xbffff700) at gmain.c:652
#11 0x4062e277 in g_main_iterate (block=1, dispatch=1) at gmain.c:870
#12 0x4062e3f9 in g_main_run (loop=0x81adf20) at gmain.c:928
#13 0x4055eedf in gtk_main () at gtkmain.c:475
#14 0x4049d80f in nsAppShell::Run (this=0x80a0ab0) at
../../../../widget/src/gtk/nsAppShell.cpp:395
#15 0x4032a031 in nsAppShellService::Run (this=0x809fdb8) at
../../../../xpfe/appshell/src/nsAppShellService.cpp:480
#16 0x804c85c in main1 (argc=1, argv=0xbffff914) at
../../../xpfe/bootstrap/nsAppRunner.cpp:577
#17 0x804cae9 in main (argc=1, argv=0xbffff914) at
../../../xpfe/bootstrap/nsAppRunner.cpp:667



I am also going to attach a png of the button I pressed.
(Reporter)

Comment 1

19 years ago
Created attachment 2665 [details]
Screen Shot

Updated

19 years ago
Severity: normal → critical
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Assignee)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Comment 2

19 years ago
5.2 is not the supported RedHat version for mozilla.  It is 6.0, please upgrade
your system. Setting this bug to Verified/Invalid.
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
(Reporter)

Comment 3

19 years ago
I do not mean to sound like a jerk or anything, but to ignore my
bug report because you do not like my system is not the right
way to interact with the user community. The problem is not
my system, this crash is the result of an unchecked null pointer
in mozilla code. I know about bug 8849 and the related issues,
AND THIS IS NOT ONE OF THEM! I am re-opening this bug.
(Assignee)

Updated

19 years ago
QA Contact: leger → claudius
Resolution: INVALID → ---
(Assignee)

Comment 4

19 years ago
claudius, try this on Redhat 6.0.  If bug does not occurs, then please Verify/
Won't Fix.

dejong@cs.umn.edu - I did not ignore.  I explained my action.  If you do not have
6.0, no problemo.  We'll give it a try over here.  If this bug does not occur
with Redhat Linux 6.0, then I am afraid it will never be fixed.  Mozilla support
is for 6.0 and above.  But let's see what claudius finds.  No worries.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
This is a duplicate of an existing bug.

*** This bug has been marked as a duplicate of 15946 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
VERIFIED dupe
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.