incompatible with Endnote

RESOLVED DUPLICATE of bug 233375

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 233375
16 years ago
2 years ago

People

(Reporter: Joseph Satriano, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016

Download from PubMed (http://www.ncbi.nlm.nih.gov/) by Mozilla was able to save
my selections (query.fcgi) on my desktop, but as an Excel file. I changed the
'Open with' to either TextEdit or MS Word, both of which work to import into
EndNote when downloaded by Internet Explorer, but the file was not recognized
and could not be imported by EndNote. I opened the file up in TextEdit and it
looked identical to the IE TextEdit download. Interestinly- the IE 'query.fcgi'
download had writing across it's desktop icon (TextEdit, I guess), whereas the
Mozilla icon was blank. I also tried Mozilla 1.1- same results.

Good luck with your Mozilla development. I prefer your browser to IE, but may
keep IE around for a little longer. Also- couldn't find a similar window to IE's
Preferences>File Helpers where the extensions and apps can be defined. 

Reproducible: Always

Steps to Reproduce:
1.Choose articles at NCBI>PubMed website and place in clipboard (ClipAdd).
2.Go to Clipboard and Display as MEDLINE (for EndNote), then SAVE.
3.Downloaded 'query.fcgi' is placed on desktop.
4. Open EndNote library and File>Import.
5. Unable to choose 'quert.fcgi' from desktop.




Don't know what to add. The Mozilla TextEdit download is not recognized by a
program looking for a TextEdit (or MS Word) document. The browser does not hang
or crash. It's been quite stable for the week or so I've used it.

Comment 1

15 years ago
Joseph, can you still reproduce this problem using a current nightly build?

Comment 2

14 years ago
Reporter, what is the document type when you do a Get Info on mozilla-downloaded
file? MSIE/TEXT, MOZZ/TEXT ?
Assignee: asa → general
QA Contact: asa → general

Comment 3

14 years ago
trying to send this to the File Handling component it might get some attention
there. From what I understand the problem is that we save the whole file with
html markup and all, while EndNote can only read the MEDLINE stuff that it
contains. Don't know why it works in IE tho.
Please send it back in browser-general if it's the wrong component, thanks.
Joseph if you can give more information on this bug, please do, thanks!
Assignee: general → file-handling
Component: Browser-General → File Handling
QA Contact: general → ian
maybe the problem is that we don't set the type/creator code on downloads but we
should... or it's that the file is stored with the wrong extension...

Comment 5

13 years ago
FireFox 1.0 OSX, query.fcgi is saved (as Text file) with no type or creator. 

EndNote's open dialog filters for type code 'TEXT', which is poor design but
allowed.

Apple recommends putting type & creator codes on all saved files.

http://developer.apple.com/documentation/MacOSX/Conceptual/BPFileSystem/Concepts/FileSystemGuidelines.html

Therefore, this is a dupe of bug 233375

*** This bug has been marked as a duplicate of 233375 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.