Download Manager stops if Mozilla crashes...

RESOLVED DUPLICATE of bug 131871

Status

SeaMonkey
Download & File Handling
RESOLVED DUPLICATE of bug 131871
16 years ago
14 years ago

People

(Reporter: Markian Zadony, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

If Mozilla crashes for any reason, it also takes down and kills all active
downloads.  I can tell that the Download Manager (DM) is a sub-process under
Mozilla.  So, if Mozilla goes down, DM goes down with it.  Depending on the
source (some FTP sites), the download may not be able to be restarted from where
it left off if it's cut off mid-stream...  Because of this, if I'm downloading
many things at once, I won't be using (or not using heavily) Mozilla for browsing.

This is a bug but more of a request.  If the DM was its own app/process that was
sent what to dl from Mozilla, as long as Mozilla doesn't take down the OS (which
has never happened to me) the DM would continue to run...

Reproducible: Sometimes

Steps to Reproduce:
1. Download a file or multiple files.
2. --(Somehow) GPF Mozilla--.

Actual Results:  
The DM was killed and all active file transfers stopped.

Expected Results:  
Mozilla acted as expected in a crash... But it would be nice if it didn't kill
all transfers.

Comment 1

16 years ago
..or it would be nice if it could recover gracefully when it does fail.
e.g. a resume option for the "cancelled" (mozilla crashed) download

Comment 2

16 years ago
Probable dupe of 131871
(Reporter)

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 131871 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.