"Load opened windows in background" ignored for request coming in from AppleScripts

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: scott, Assigned: jaas)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021113 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021113 Chimera/0.6+

The "Load opened windows in background" preference is ignored if the request to
open a URL comes in through an AppleScript from another application.

For example, I have a shell script that uses osascript to "open location <url>"

If I have Chimera set to load pages requested by other applications as new tabs,
and in the background, it works correctly.

If I have Chimera set to load pages requested by other applications as new tabs,
and in the foreground, it works correctly.

However, I have unset the "load pages requested by other applications as tabs"
(indicating that I want new windows), those pages always open in the foreground,
on top of any other pages I may be currently viewing.

If the page request came from Chimera itself (for example, if I ctrl-click on a
link and select open in new window), the new window does open in the background.

This is a problem for me as I can have my script open several pages for me at
once, and I would like to start reading the first page while the others are
opened behind it

Reproducible: Always

Steps to Reproduce:
1. Set preference "load pages requested by other applications" to unselected
2. Set preference "load opened windows or tabs in the background" to set
3. From the terminal: osascript -e '$openURL "<url>"'

Actual Results:  
New window opens in front of other windows.


Expected Results:  
New window should have opened in back of other windows

Updated

16 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

15 years ago
Assignee: sfraser → josha
Status: ASSIGNED → NEW
Ping

Wow... this is an old bug.

Is this on anyone's radar? Can we confirm it again? Hasn't really been touched
since 06, it appears...
Yeah, I'll reconfirm.

If "Link from other application" is set to "Opens in a new tab in the frontmost
window", then the URL is opened in a background tab.

If it's set to "Opens in a new window", however, it always opens in a new window
in the foreground.

Comment 3

14 years ago
This is already the behavior that we want. The load windows and tabs in the
background occurs while Camino is the active application.

The typical case when launching links from other apps is to read them at that time.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.