Shockwave plugin crashes and closes browser windows [@ PluginPing.dll]

VERIFIED FIXED

Status

Plugins Graveyard
Shockwave (Adobe)
--
critical
VERIFIED FIXED
15 years ago
2 years ago

People

(Reporter: K, Assigned: Roy Yokoyama)

Tracking

({crash, shockwave})

x86
Windows XP
crash, shockwave

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021118
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021118

Shockwave presentation at http://surface.yugop.com. Need Flash & Shockwave.
Click number 31, 3rd button from the right, titled Clocksphere. Once I click on
it, the browser crashes, XP message about 'send error' pops up, and every
Mozilla window is closed. There are other Shockwave presentations, but I
happened to land on number 31.

Reproducible: Always

Steps to Reproduce:
1. Go to http://surface.yugop.com
2. Bottom menu, click 3rd button from the left, #31: Clocksphere
3. Browser crashes

Actual Results:  
Browser crashed and windows closed

Expected Results:  
Play the Shockwave presentation
(Reporter)

Comment 1

15 years ago
Using Mozilla 1.3a
Version: Trunk → 1.0 Branch
Do you have a Talkback ID from that crash ?
Version: 1.0 Branch → Trunk

Updated

15 years ago

Comment 3

15 years ago
Do you still crash when upgrading to Flash 6 ?

Comment 4

15 years ago
I have
Shockwave Flash

    File name: npswf32.dll
    Shockwave Flash 5.0 r41

and 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021118
And it crashes for me as soon as it tries to load surface.yugop.com before even
getting a choice to click on the specified button.  I have a talkback saved, but
it hasn't sent yet for some reason, seems to be having problem talking to the
talk back server, I can tell you the TID when it submits finally.

I've not tried upgrading to flash 6, but I still wouldn't be expecting it to
crash.  www.nidecker.com also crashes for me immediately.
Karl Palsson: you are seeing a different crash. This bug is different becuase
the reporter crashes only if he clicks a link inside the flash plugin.

You see bug 179822 (flash 4/5 problem but flash6 works))

Comment 6

15 years ago
Never mind then :)  Thanks for the prompt reply.  I just installed flash 6
though anyway, and the reporters original problem works for me now. My old
problem is well and truly gone.

Cheers,
Karl P

Confirmed with build 2002111908
I also noticed a similar bug when you try to open a swf file attached in a mail
message.

Is it because of the checkin of  bug 110729 ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
pascal.chevrel@free.fr: 
What do you see ?
WHich flash version do you use ?
Do you get a crash if you open the URL or if you click on the link inside the
flash ?
Do you have a talkback ID ?
(Reporter)

Comment 9

15 years ago
what do I do to enable Talkbalk in Moz 1.3a? Or is it already enabled?
Do you have :
Mozilla/components/talkback.exe ?

Comment 11

15 years ago
tested this and certainly did crash.
winXP
2002111808 build (trunk)
Shockwave Flash
    File name: npswf32.dll
    Shockwave Flash 6.0 r47
Shockwave for Director
    File name: np32dsw.dll
    Macromedia Shockwave for Director Netscape plug-in, version 8.5

Talkback ID: 14139297

Comment 12

15 years ago
Created attachment 106858 [details]
talkback report

Talkback report
Beppe: Could this be the same crash as the flash4/5 one ?
In this case the shockwave director plugin crashes (and not flash6).
The stacks looks near identical. (what is : PluginPing.dll ?)

Comment 14

15 years ago
it's a macromedia file, adding emillard for help on this on. Can you point me to
the correct person?

Comment 15

15 years ago
oh yeah, they are pretty much the same stack aren't they -- hmm adding Peter for
confirmation on this

Comment 16

15 years ago
I'm pretty sure the cause of this is the same as for bug 179822,
turning on MOZ_UNICODE (bug 104934) causes the crash old macromedia's WinProc.
I would not mark it as a dup of 179822, because that bug is about crash in old
flash5, and there's workaround - upgrade to flash 6.
This bug is about to crash in
%windir%\system32\Macromrded\Shockware 8\PluginPing.dll, which is part of
Macromedia Shockwave for Director Netscape plug-in, version 8.5, I'm not aware
if there is new version of Shockwave for Director available.

Comment 17

15 years ago
yes, I added emillard to get exposure from macromedia side
(Assignee)

Comment 18

15 years ago
Beppe: I suspect it's the same crash as the flash4/5 one.
       Can you try to upgrade to flash 6; but leave the shockware as is?

Comment 19

15 years ago
Roy, what Serge is saying is that Flash and Shockwave are two different plugins.
This bug is about Shockwave. Both are made by the same company and very likely
share some code, so the cause for the crash can be similar, but they are still
different plugins. If we find a solution for one, it will likely solve another.
(Reporter)

Comment 20

15 years ago
well at least its working on Moz 1.1

btw, how did Moz jump from 1.2b to 1.3a? whatever happened to full 1.2?

Comment 21

15 years ago
Roy: I do have Flash 6 installed. As Andrei, Serge and I explained - Shockwave
is an independent plug-in from Macromedia, but we suspect they used the same
core code.

Comment 22

15 years ago
reassigning

Comment 23

15 years ago
really reassigning
Assignee: beppe → yokoyama
(Assignee)

Comment 24

15 years ago
taking; but I need help from macromedia. See bug 179822
Status: NEW → ASSIGNED
(Assignee)

Updated

15 years ago
Target Milestone: --- → mozilla1.3alpha

Updated

15 years ago
Keywords: shockwave
Depends on: 179822
Summary: Shockwave plugin crashes and closes browser windows → Shockwave plugin crashes and closes browser windows [@ PluginPing.dll]
*** Bug 182201 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 26

15 years ago
Build with the latest patch in 179822 doesn't crash from visiting 
http://surface.yugop.com/
I think this will get fixed once we check in the fix for 179822.

(Assignee)

Comment 27

15 years ago
fix for 179822 is checked into the trunk.
Please verify this bug. Thanks
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 28

15 years ago
this crash is indeed fixed. I do not crash on 1204 trunk build on Xp. Reporter,
pls double check, Thanks !!
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Plug-ins → Shockwave (Adobe)
Product: Core → Plugins
QA Contact: shrir → adobe-shockwave
Target Milestone: mozilla1.3alpha → ---
Version: Trunk → 8.x
Crash Signature: [@ PluginPing.dll]
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.