Closed Bug 1809685 Opened 1 year ago Closed 4 months ago

Missing UI for dom.events.asyncClipboard.clipboardItem

Categories

(Core :: DOM: Copy & Paste and Drag & Drop, enhancement)

Firefox 110
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1770358
Tracking Status
firefox110 --- affected

People

(Reporter: hwine, Unassigned)

References

Details

(Keywords: nightly-community)

Attachments

(1 file)

With the dom.events.asyncClipboard.clipboardItem default value of false, vs-code in browser no longer can access the clipboard. With the setting manually set to 'true', vs-code in browser works as before.

There is no UI available for the permission, as is suggested in sumo.

STR:
Prerequisites: GitHub account & repo you have write access to.

  1. log into GitHub and navigate to a writable-by-you repo
  2. press '.' (period) to activate the vscode-in-browser feature
  3. open a file, and attempt to paste additional content

Expected Behavior

  • text on clipboard is successfully added to document

Actual Behavior

  • text is not added
  • alert is displayed by vscode-in-browser (see attached image)
Type: defect → enhancement
Component: DOM: Events → DOM: Copy & Paste and Drag & Drop

I don't think there is any point in adding a UI option for this. We should just wait for these prefs to be enabled by default.

Status: NEW → RESOLVED
Closed: 4 months ago
Duplicate of bug: 1770358
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: