Adding keyword from enter_bug doesn't update keyword cache

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Creating/Changing Bugs
--
major
RESOLVED FIXED
16 years ago
5 years ago

People

(Reporter: bbaetz, Assigned: bbaetz)

Tracking

2.17.1
Bugzilla 2.18
x86
Linux
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
When you enter a bug from the enter_bug page, post_bug doesn't update the
keyword cache on the bugs table, so subsequent modifications show the first
other person to do anything as having made teh change, in both bug mail and teh
activity log

Patch coming.

The keyword cache is evil ;)
(Assignee)

Comment 1

16 years ago
Created attachment 106843 [details] [diff] [review]
patch

Here we go. Code basically grabbed from process_bug, with a couple of
simplifications since we know that there we no keywords on teh bug to start
with...
(Assignee)

Updated

16 years ago
Attachment #106843 - Flags: review?(myk)
Comment on attachment 106843 [details] [diff] [review]
patch

Yup, that's it.  r=myk
Attachment #106843 - Flags: review?(myk) → review+
Flags: approval+
(Assignee)

Comment 3

16 years ago
Fixed in CVS
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 4

16 years ago
*** Bug 180561 has been marked as a duplicate of this bug. ***
Target Milestone: --- → Bugzilla 2.18
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.