Closed Bug 1809850 Opened 1 year ago Closed 1 year ago

firefox desktop compile error

Categories

(Firefox Build System :: General, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1718171

People

(Reporter: gzyfqh, Unassigned)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/111.0.0.0 Safari/537.36

Steps to reproduce:

Use msvs2019+sdk20348 to compile firefox desktop on the windows system, many errors occurs during the compilation process.

Customized mozconfig and modified the source code before compiling

Actual results:

48:07.98 lld-link: error: undefined symbol: __llvm_profile_instrument_memop
48:07.98 >>> referenced by pbproxy.obj:(public: static wchar_t * __cdecl std::_Char_traits<wchar_t, unsigned short>::move(wchar_t *const, wchar_t const *const, unsigned __int64))
48:07.98 >>> referenced by pbproxy.obj:(public: static wchar_t * __cdecl std::_Char_traits<wchar_t, unsigned short>::copy(wchar_t *const, wchar_t const *const, unsigned __int64))
48:07.98 make[4]: *** [E:/mozilla-source/mozilla-unified/config/rules.mk:426: ../../../dist/bin/private_browsing.exe] Error 1
48:07.99 make[3]: *** [E:/mozilla-source/mozilla-unified/config/recurse.mk:72: browser/app/pbproxy/target] Error 2
48:07.99 make[3]: *** Waiting for unfinished jobs....
48:16.04 Microsoft (R) Macro Assembler (x64) Version 14.29.30147.0
48:16.04 Copyright (C) Microsoft Corporation. All rights reserved.
48:16.04 Assembling: E:/mozilla-source/mozilla-unified/security/nss/lib/freebl/arcfour-amd64-masm.asm
48:16.10 Microsoft (R) Macro Assembler (x64) Version 14.29.30147.0
48:16.10 Copyright (C) Microsoft Corporation. All rights reserved.
48:16.12 Assembling: E:/mozilla-source/mozilla-unified/security/nss/lib/freebl/intel-aes-x64-masm.asm
48:16.14 Microsoft (R) Macro Assembler (x64) Version 14.29.30147.0
48:16.14 Copyright (C) Microsoft Corporation. All rights reserved.
48:16.15 Assembling: E:/mozilla-source/mozilla-unified/security/nss/lib/freebl/intel-gcm-x64-masm.asm
48:16.18 Microsoft (R) Macro Assembler (x64) Version 14.29.30147.0
48:16.18 Copyright (C) Microsoft Corporation. All rights reserved.
48:16.21 Microsoft (R) Macro Assembler (x64) Version 14.29.30147.0
48:16.21 Copyright (C) Microsoft Corporation. All rights reserved.
48:16.21 Assembling: E:/mozilla-source/mozilla-unified/security/nss/lib/freebl/mpi/mp_comba_amd64_masm.asm
48:16.21 Assembling: E:/mozilla-source/mozilla-unified/security/nss/lib/freebl/mpi/mpi_amd64_masm.asm
48:23.67 Compiling smallvec v1.10.0
48:23.67 Compiling pkcs11-bindings v0.1.4
48:24.32 Compiling builtins-static v0.1.0 (E:\mozilla-source\mozilla-unified\security\manager\ssl\builtins)
48:28.15 Finished release [optimized] target(s) in 21.84s
48:28.31 make[2]: *** [E:/mozilla-source/mozilla-unified/config/recurse.mk:34: compile] Error 2
48:28.32 make[1]: *** [E:/mozilla-source/mozilla-unified/config/rules.mk:361: default] Error 2
48:28.32 make: *** [client.mk:60: build] Error 2
48:28.38 526 compiler warnings present.

Expected results:

Can compile firefox desktop normally

Attached file mozconfig
Attached file ## Copyright (c) 202
Attached file mozconfig

The Bugbug bot thinks this bug should belong to the 'Firefox Build System::General' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → General
Product: Firefox → Firefox Build System

I think this is essentially a duplicate of bug 1718171. I think your options here (for now) are to either remove export MOZ_PGO=1 and ac_add_options MOZ_PGO=1 from your mozconfig, or do a cross-compile on Linux (With Windows as the target) if you want a build with PGO enabled.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Duplicate of bug: 1718171
Resolution: --- → DUPLICATE

I was able to build successfully after removing those flags (export MOZ_PGO=1 and ac_add_options MOZ_PGO=1) and your specific branding flags from the mozconfig you provided. I hope that helps.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: