nsStatusBarBiffManager::~nsStatusBarBiffManager() unconditionally releases a null member

VERIFIED DUPLICATE of bug 180995

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED DUPLICATE of bug 180995
15 years ago
9 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

15 years ago
+	kBiffStateAtom	0x00000000
    NS_RELEASE(kBiffStateAtom);

nsStatusBarBiffManager::~nsStatusBarBiffManager() line 76 + 6 bytes
nsStatusBarBiffManager::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsStatusBarBiffManager::Release(nsStatusBarBiffManager * const 0x03d0aca0) line
64 + 179 bytes
nsCOMPtr_base::assign_assuming_AddRef(nsISupports * 0x00000000) line 436
nsCOMPtr_base::assign_with_AddRef(nsISupports * 0x00000000) line 74
nsCOMPtr<nsISupports>::operator=(nsISupports * 0x00000000) line 796
FreeServiceContractIDEntryEnumerate(PLDHashTable * 0x004a676c, PLDHashEntryHdr *
0x010514b4, unsigned int 319, void * 0x00000000) line 1926
PL_DHashTableEnumerate(PLDHashTable * 0x004a676c, int (PLDHashTable *,
PLDHashEntryHdr *, unsigned int, void *)* 0x0029b1f0
FreeServiceContractIDEntryEnumerate(PLDHashTable *, PLDHashEntryHdr *, unsigned
int, void *), void * 0x00000000) line 603 + 34 bytes
nsComponentManagerImpl::FreeServices() line 1938 + 19 bytes
NS_ShutdownXPCOM(nsIServiceManager * 0x00000000) line 723
main(int 2, char * * 0x004a4424) line 949 + 8 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e87903()
*** Bug 180999 has been marked as a duplicate of this bug. ***
*** Bug 181001 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 180995 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Keywords: crash
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

15 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
(Assignee)

Updated

9 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.