JavaScript based dropdown menu not working

VERIFIED DUPLICATE of bug 163503

Status

()

VERIFIED DUPLICATE of bug 163503
16 years ago
16 years ago

People

(Reporter: daniel.n.nilsson, Assigned: rogerl)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021114
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021114

On the page referenced in the URL, there are dropdown menus on the right side of
the page "browse brands" "browse products" etc. These menus can be dropped down,
but when you try to make a selection, the menu doesn't stay up so no selection
can be made.


Reproducible: Always

Steps to Reproduce:
This has nothing to do with JS, and it's not a JS-based dropdown menu...  The
<select> is inside a <span> with :hover style on it.

*** This bug has been marked as a duplicate of 163503 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified Duplicate -


<div class="smalltxt">
  <select ONCHANGE="gotosite(this.options[this.selectedIndex].value)"
          NAME=URL class=dropdown> 
    <option SELECTED>Browse Brands

               etc.


Meanwhile, from http://www.horizonhobby.com/ie_style_v1.css,
this is defined:

.smalltxt:hover
{ 
  font-family: arial;
  font-size : 11px;
  color : #ffcc33;
}


Note, as mentioned in bug 163503 comment 13, the problem is confined
to Linux only. Indeed, the site given in this bug works fine with
Mozilla trunk binary 20021115xx on WinNT.


Daniel: thank you for this report. You have been cc'ed on bug 163503
so you can follow progress on this issue -
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

16 years ago
I'm sorry about the duplicate, couldn't find any bug reported against this
website and the first time through the html source it appeared to be heavily
based on javascript. I went back and read the page source again and I now
realize this specfic menu has nothing todo with javascript :-(

Anyway, thanks for moving this bug to the right area.
You need to log in before you can comment on or make changes to this bug.