mouseless navigation: element focus not remembered when returning to previous page

VERIFIED DUPLICATE of bug 36539

Status

()

Core
Keyboard: Navigation
VERIFIED DUPLICATE of bug 36539
15 years ago
15 years ago

People

(Reporter: Leston Buell, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021109
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021109

Sorry, couldn't decide on what the appropriate component was for this.

This is an issue for mouseless navigation. When you use the tab key to tab
through links and then hit Enter to visit the link, if you return to the
original page (by hitting the back button, for example), the browser will
remember the scroll position, but not the element in focus. If you hit the tab
key, you'll be returned to the first focusable element from the top of the page.
This makes mouseless navigation very tedious if you're trying to visit several
links from a single page.

Reproducible: Always

Steps to Reproduce:
1. Visit the Bulbul's Links page at  
   <http://www.fizzylogic.com/users/bulbul/links.html>.
2. Tab down to a link low in the page. Visit the link by pressing Enter.
3. Return to Bulbul's Links by hitting Back or keying Alt+<-.
4. Try to visit the next link on that page, mouselessly. 
   The link which was in focus when you left the page is no 
   longer in focus.
   If you press tab, you'll be returned to the top of the page 
   and will need to tab all the way down again. 
   There's no way to go straight to the next link.
"keyboard navigation".  ;)

And this is a duplicate
Assignee: asa → aaronl
Component: Browser-General → Keyboard Navigation
QA Contact: asa → sairuh
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 36539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
v dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.