Make flag descriptions visible to bugzilla users

RESOLVED FIXED in Bugzilla 2.22

Status

()

Bugzilla
Attachments & Requests
--
enhancement
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: asa, Assigned: robzilla)

Tracking

2.17.1
Bugzilla 2.22
Bug Flags:
approval +

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

15 years ago
We currently have descriptions in the management interface for flags. It would
be really good if this was made visible in the bug. Several mechanisms for
making this visible are:
1. mouse over the flag in show_bug and see a description in a tooltip (title
attribute). 
2. like activestate's bugzilla, put a little information "i" icon next to the
flag which when clicked makes a popup window with a description of that flag. 
3. create something like describekeywords but for flags. 

1 & 2 appeal a lot more to me than 3 but 3 might be easiest. The reason I like 1
and 2 is that flags can be product and component specific and there may be
similarly named flags with different description so attaching a description to
the speficif flag the users is looking at is more appealing than a big flat list
with all flags.

Comment 1

13 years ago
Created attachment 178600 [details] [diff] [review]
draft
Attachment #178600 - Flags: review?(justdave)

Comment 2

13 years ago
Created attachment 178623 [details] [diff] [review]
draft 2

Draft 2 - fixes a minor issue with Timely's patch
(Reporter)

Comment 3

13 years ago
Just a quick note, I do not want this enabled at b.m.o. until I've had a chance
to clean up the descriptions. 

Comment 4

13 years ago
Created attachment 178682 [details] [diff] [review]
Patch v1

Patch v1

This merges all the draft comments, and fixes a couple of minor bugs in them.

Updated

13 years ago
Attachment #178600 - Attachment is obsolete: true
Attachment #178623 - Attachment is obsolete: true
Attachment #178682 - Flags: review?(LpSolit)

Updated

13 years ago
Attachment #178600 - Flags: review?(justdave)

Comment 5

13 years ago
Comment on attachment 178682 [details] [diff] [review]
Patch v1

>     # Get a list of request type names to use in the filter form.
>-    my @types = ("all");
>-    SendSQL("SELECT DISTINCT(name) FROM flagtypes ORDER BY name");
>-    push(@types, FetchOneColumn()) while MoreSQLData();
>+    my %types;
>+    $types{'all'} = { description => '' };
>+    SendSQL("SELECT DISTINCT(name), description FROM flagtypes ORDER BY name");
>+    while (MoreSQLData()) {
>+        my ($name, $description) = FetchSQLData();
>+        $types{$name} = { description => $description};
>+    }

flag type names are not unique. Doing so, all flag types with the same name
will have the same description. Of course, this is wrong. Moreover, please use
the new DBI stuff instead of the old SendSQL/MoreSQLData one.
Attachment #178682 - Flags: review?(LpSolit) → review-

Updated

13 years ago
Target Milestone: --- → Bugzilla 2.22
(Assignee)

Comment 6

13 years ago
Created attachment 184939 [details] [diff] [review]
robzilla_v1

This shows the flag description in a tooltip.
Assignee: myk → robzilla
Attachment #178682 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #184939 - Flags: review?

Comment 7

13 years ago
*** Bug 296072 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
Comment on attachment 184939 [details] [diff] [review]
robzilla_v1

>         <td>
>-          [% type.name FILTER html FILTER no_break %]
>+          <label title="[% type.description FILTER html %]">
>+            [%- type.name FILTER html FILTER no_break %]</label>
>         </td>

Nice patch. But it would be fine to have tooltips even when hovering the
dropdown menu. It seems possible to do it by adding a title="" to the select
element. Moreover, you missed the multiplicable flags around line 180.
Attachment #184939 - Flags: review? → review-
(Assignee)

Comment 9

13 years ago
Created attachment 185010 [details] [diff] [review]
robzilla_v2
Attachment #184939 - Attachment is obsolete: true
Attachment #185010 - Flags: review?(LpSolit)

Comment 10

13 years ago
Comment on attachment 185010 [details] [diff] [review]
robzilla_v2

nice patch. r=LpSolit
Attachment #185010 - Flags: review?(LpSolit) → review+

Updated

13 years ago
Flags: approval?
Flags: approval? → approval+
QA Contact: mattyt-bugzilla → default-qa

Comment 11

13 years ago
Checking in template/en/default/flag/list.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/flag/list.html.tmpl,v 
<--  list.html.tmpl
new revision: 1.18; previous revision: 1.17
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Keywords: relnote
*** Bug 304592 has been marked as a duplicate of this bug. ***

Comment 13

12 years ago
*** Bug 325266 has been marked as a duplicate of this bug. ***

Comment 14

12 years ago
Added to the Bugzilla 2.22 Release Notes in bug 322960.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.