deepmetrix.com - LiveStats login page does not display

RESOLVED FIXED in Oct

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Sam Hulick, Unassigned)

Tracking

unspecified

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016

LiveStats login page does not display at all.  Also try
http://livestats.gearhost.com:8080

Reproducible: Always

Steps to Reproduce:
Visit http://stats.hitnet.net/
Actual Results:  
blank page

Expected Results:  
Shown a page

Comment 1

15 years ago
The javascriptConsole give these error, probably Tech Evang:

http://stats.hitnet.net/
Error: uncaught exception: [Exception... "Component returned failure code:
0x804b0012 [nsIDOMLocation.href]"  nsresult: "0x804b0012 (<unknown>)"  location:
"JS frame :: http://stats.hitnet.net/jscript/bdetect.js :: <TOP_LEVEL> :: line
1"  data: no]

http://livestats.gearhost.com:8080
Error: uncaught exception: [Exception... "Component returned failure code:
0x804b0012 [nsIDOMLocation.href]"  nsresult: "0x804b0012 (<unknown>)"  location:
"JS frame :: http://livestats.gearhost.com:8080/jscript/bdetect.js ::
<TOP_LEVEL> :: line 1"  data: no]
Assignee: asa → jst
Component: Browser-General → DOM Level 0
QA Contact: asa → desale

Comment 2

15 years ago
WFM using buildID 2002111108 on WinXPSP1

Reporter: could you try a more recent buildID and report back?

Comment 3

15 years ago
I'm guess the people who are seeing this dont have the java-plugin installed. Right?

Looks like this site really doesnt like browsers that dont have java enabled. 

The browser sniffing at http://stats.hitnet.net/jscript/bdetect.js
looks like this ... (slightly beautified for readability)

/*V1.1*/
if(parseInt(navigator.appVersion.substring(0,1)) < 4)
  {location.href = "";}
else if(!navigator.javaEnabled())
       {location.href = "";}
else {if (document.layers ||(!document.all && !document.layers))
        {if(!window.frames){location.href = "";}}
else if(document.all){if(!document.frames){location.href = "";}}}


So if you dont have java enabled you are out of luck, you will end up at 
location = ""

This bug may be kept open to consider whether we should be throwing an exception
if a script does location.href="".

But other than that, I guess you just have to evangelize the webmaster for
allowing in java-less browsers in.

Comment 4

15 years ago
Harshal, you are right. With java disabled I get a blank page, but with java
enabled the site works.
Mass-reassigning bugs to dom_bugs@netscape.com
Assignee: jst → dom_bugs

Comment 6

15 years ago
-> Tech Evangelism

re comment 3
> This bug may be kept open to consider whether we should be throwing
> an exception if a script does location.href=""

that may be bug 101276
Assignee: dom_bugs → susiew
Component: DOM Level 0 → US General
Product: Browser → Tech Evangelism
QA Contact: desale → zach
Version: Trunk → unspecified

Comment 7

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Comment 8

14 years ago
confirm bug and that the issue is java disabled/not installed with an infinite
direct due to the assignment of '' to location.
webmaster@deepmetrix.com
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: DeepMetrix LiveStats login page does not display → deepmetrix.com - LiveStats login page does not display
Target Milestone: --- → Oct

Comment 9

13 years ago
[bug248549notfixed]

Comment 10

7 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE

Comment 11

7 years ago
Site has gone away -> INVALID
Resolution: INCOMPLETE → INVALID

Comment 12

7 years ago
(In reply to comment #11)
> Site has gone away -> INVALID

For future reference, we typically regard these sort of bugs as FIXED by death of site.
Resolution: INVALID → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.