dinamic html changes page layout (doesn't respect table constraints)

RESOLVED DUPLICATE of bug 175455

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 175455
15 years ago
15 years ago

People

(Reporter: Merisescu Cosmin, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016

if i press more times on the buttons (let's say the button "Create") the layout
enlarges, when it should stay the same

Reproducible: Always

Steps to Reproduce:
1.Go to http://devel.kondiment.com/ksp/admin/main.htm
2.Press several times on any button(ex: "Create")
3.

Actual Results:  
the layout enlarges

Expected Results:  
table size should remain the same
table layout; nothing to do with compositor.
Assignee: kmcclusk → table
Component: GFX Compositor → Layout: Tables
QA Contact: ian → amar

Comment 2

15 years ago
this might be a dupe of bug 175455, a testcase would be fine

Comment 3

15 years ago
Created attachment 106950 [details]
minimal testcase

Minimal testcase based on the site. There's some similarity with the testcases
in bug 175455 (the padding), but I can't determine if it's indeed the same
problem.
(Reporter)

Comment 4

15 years ago
i've tried your source:
<body>
<table>
<tbody><tr>
  <td>
    <div style="width: 100%; padding-right: 5px;">
      <table width="100%" cellspacing="0">
        <tbody><tr>
          <td align="center">
            <input type="button" value="Click to move">
          </td>
        </tr>
      </tbody></table>
    </div>
  </td>
</tr>
</tbody></table>
</body></html>

and seen that it has the same behaviour as i do. Removing the padding-right:5px
from the <div> style, the problem dissappeared. I think that there is some
padding incrementation when pressing the button. Each time the html is
processed, the padding is incremented (try putting a flag which blocks padding
incrementing each time html is processed).

Comment 5

15 years ago
confirmed... its causing the problem when style is used with " width: 100%; and
padding-left or padding-right" . Its a dupe of bug 175455.

*** This bug has been marked as a duplicate of 175455 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
oops The problem in the bug 175455 is caused by "font-weight: bold;" not by "
width: 100%; and padding-left". Reopening this bug
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

15 years ago
> The problem in the bug 175455 is caused by "font-weight: bold;"

actually, the style change on hover for bug 175455 can be anything that causes a
reflow ('font-size', different 'padding-left', etc.).  The reflow here is caused
by the button being pushed.

regression between linux trunk builds 2002090312 and 2002090421 (same as bug 175455)

re-marking dupe

*** This bug has been marked as a duplicate of 175455 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Keywords: regression
OS: Windows XP → All
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.