crash with applets if app filename contains a slash '/'

RESOLVED WORKSFORME

Status

Camino Graveyard
Plug-ins
P1
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Chris Petersen, Assigned: Peter Lubczynski)

Tracking

({crash, regression})

unspecified
Camino0.7
PowerPC
Mac OS X
crash, regression

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Build: 2002-11-19-12
Platform: OS X 10.2.2
Expected Results: Applet on page should intialize and appear on page
What I got: Application crashes

Steps to reproduce:

1) Load a site which contains a applet like
http://mozilla.org/quality/browser/standards/html/applet_align_left.html

2) Application crashes
(Reporter)

Comment 1

15 years ago
Created attachment 106928 [details]
Stack trace
(Reporter)

Comment 2

15 years ago
This problem is not occuring with the 2002-11-18-04 NB under 10.2.2.
Keywords: regression

Comment 3

15 years ago
->peterl
Assignee: bnesse → peterl
(Reporter)

Comment 4

15 years ago
Two additional issues:

1) This doesn't occur under 10.1.5 using the same build (2002-11-19-12)

2) If I removed the MRJ plugin from the package, Chimera will load and intialize
the applet properly.
(Reporter)

Updated

15 years ago
Priority: -- → P1
strangely, i cannot repro this using 2002.11.21.04 bits on 10.2.2.
Keywords: crash
(Reporter)

Comment 6

15 years ago
This bug is randomly happening on my Dual 800 G4. Today's build (2002-12-05-04)
crashes when intializing any applet like the sample test case provided. The
build from the previous day (2002-12-04-04) loads and displays the applet test
case properly. Tested under 10.2.2.
(Reporter)

Comment 7

15 years ago
I know realize why this is crashing. If have a "/" character in the name of the
application like 'Nav 12/05', the app wil crash when loading a applet.

Updated

15 years ago
Summary: Attempting to load a page containing a applet results in a crash → crash with applets if app filename contains a slash '/'

Comment 8

15 years ago
Chris, does that apply to all builds or just the ones you noted?
(Reporter)

Comment 9

15 years ago
I can reproduce on the 0.6 milestone in addition to today's build. Haven't tried
in the latest OS X trunk build.

Comment 10

15 years ago
isn't the slash a reserved character?
Target Milestone: --- → Chimera0.7
(Reporter)

Updated

15 years ago
Severity: blocker → major

Comment 11

15 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: major → critical
(Reporter)

Comment 12

14 years ago
I can't reproduce this issue using the 2003-08-10-02 Chimera NB running under
10.2.6. 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.