loading tha site crashes this nightly (when using Flash plugin v5)

VERIFIED WONTFIX

Status

()

Firefox
General
--
critical
VERIFIED WONTFIX
16 years ago
15 years ago

People

(Reporter: Al Unterberger, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (compatible; X11)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021119 Phoenix/0.4

loading tha site given above crashes this nightly build (Mozilla/5.0 (Windows;
U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021119 Phoenix/0.4). This was not
happening with the Phoenix 0.4 milestone release!
btw. I was copying the nightly build to an empty directory as directed and using
a new user profile.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021119
Phoenix/0.4

Comment 2

16 years ago
WFM on 20021119 on WinXP
Al, what Flash version you have? The site has a Macromedia Flash ad on the top.
Install Flash6 or remove old Netscape folder and its Flash5 plugin.
(Reporter)

Comment 3

16 years ago
 Arthur,
thanks a lot for the info. that exactly was it!
Was using the Flash 5 plugin and after deleting that, the Phoenix nightly build
didn't crash anymore. I'm going to install the Flash 6 version, hope this works...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
Other sites that cause this:  http://www.arstechnica.com/
http://www.tomshardware.com/

Verified on latest nightly.

I left my version of Flash the same and instead reverted back to an older
nightly.  That solved the problem.  I'm blaming this on Phoenix.  It probably
has something to do with Flash though.

This bug should be re-opened.
(Reporter)

Comment 5

16 years ago
re-opening tha bug.
crash does only occur if using Flash plugin v5, with Flash version 6 tha problem
is gone.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Summary: loading tha site crashes this nightly → loading tha site crashes this nightly (when using Flash plugin v5)

Comment 6

16 years ago
Well I forgot to mention in Comment #2, but I myself had submit 
Bug 179464 and I marked it as a dupe of 176955.
Then Bug 176955 is now marked RESOLVED, how do you guys think about this
(who owes the problem, Flash or Phoenix, etc.)

Comment 7

16 years ago
This bug may be a regression rather than a duplicate of Bug 176955.  I switched
back to vanilla 0.4 (10/29, I believe) and verified that everything worked.  Bug
176955 refers to build 20021026.  Build 0.4 also predates your Bug 179464 which
refers to build 20021110.
I retested everything and was able to verify this bug on build 20021114 (the
earliest nightly I had access to.)  It is still present on 20021120.  As I said
before, vanilla 0.4 has no problem  (and 20021025 was fine as well).  
We should find what change between 10/29 and 11/10 (11/14?) broke compatibility
between Phoenix and Flash 5.  After we isolate that, we can make the decision
whether to remove that change or to require Flash 6 for Phoenix.

Comment 8

16 years ago
Flash 5 is not supported by Phoenix. Yes, I know Flash 6 is only a beta, but it
is far better than Flash 5 ever was with regards to Mozilla/Phoenix anyway.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX

Comment 9

16 years ago
Well, you'd better have a big installation warning message, because when a
number of Phoenix users upgrade to from 0.4 to 0.5 and find that their favorite
web pages simply crash Phoenix with no useful error message, there'll be a bit
of a problem.

And besides, do you know what exactly broke Flash 5 compatibility?  Until you
know that, you can't know that the problem is Flash 5 specific.  I'd be
surprised if it were.  I find it very strange that Flash 5 started crashing the
entire browser overnight.

Comment 10

15 years ago
VERIFYING obvious WONTFIX bugs.  Filter on firebirdWontFix to filter these bugs.
 I skipped a few that I'm unsure about from their summary and will manually go
through them.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.