Cannot copy/paste Japanese text to/from non-Unicode programs such as MS Word, Entourage

RESOLVED WORKSFORME

Status

Camino Graveyard
General
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Benjamin Kennedy, Assigned: Simon Fraser)

Tracking

({intl})

Details

(Whiteboard: fixed on trunk)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021119 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021119 Chimera/0.6+

When copying/pasting Japanese text to/from a non-Unicode compliant program such
as MS Word or Entourage, a get gibberish instead of the Japanese I copied. It
works fine to/from TextEdit, I suspect because it supports Unicode. However,
TextEdit and Word can copy and paste back and forth successfully.

Reproducible: Always

Steps to Reproduce:
1.Type some Japanese text in MS Word.
2.Select it and copy it.
3.Try to paste it into Chimera/Mozilla.

Actual Results:  
I got "ì˙ñ{åÍ".

Expected Results:  
It should have shown the text I copied.

Comment 1

15 years ago
It works if the text is pasted into the URL field, but not if it's pasted into a
text field in the content area.
Keywords: intl

Comment 2

15 years ago
Yeah, I ran into the same problem copying japanese content *from* the content
area in Chimera.  I can paste it into TextEdit, but when I try pasting it into
JEDict I just get a string of ???? (coping the string from TextEdit to JEDict
works fine, but it's an annoying workarround)
(Assignee)

Comment 3

15 years ago
This is mozilla bug 163908. The fix was to include 'style' data on the copy. The
problem with that is that you end up pasting styled text every time when copying
from web pages, which is also an annoyance.
Assignee: saari → sfraser
Status: UNCONFIRMED → NEW
Depends on: 163908
Ever confirmed: true
Whiteboard: fixed on trunk

Comment 4

15 years ago
Is this a dupe of bug 79864?

Comment 5

13 years ago
WFM using 20050214 NB on 10.3.8. This seems to have been fixed a while ago.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.