After an OS crash one of my pop accounts downloaded all messages from server (duplicated...)

RESOLVED INVALID

Status

RESOLVED INVALID
16 years ago
10 years ago

People

(Reporter: bcatelin, Assigned: naving)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

I'm not sure of all the details Because my computer freezed during my work time...
I try to be precise, history:
computer on.. I go to work..
My home is near work.. during work time I come home and see blue screen (freezed
on alcatel speedtouch USB .sys according to this nice blue screen). I reboot my
computer and go to work again.
Work finished I come home, launch mozilla mail, and one (only one of my 10 pop
accounts and 1 imap account) download 519 messages...
So all my messages are duplicated..
My settings are: leave messages on server, delete if deleted locally.
Maybe my computer freezed during an action of mozilla, a file was corrupted?

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.




freezed on alcan5wn.sys (version V142.2E when I click on driver details in
device manager) and 142.2.0.500 on main "driver" tab.

Comment 1

16 years ago
Hi,
Check your e-mail ssettings in preferences maybe something happened in there
because I never heard of that before.
(Reporter)

Comment 2

16 years ago
Hi
unchecked: use secure connection & empty trash on exit
checked: check for new messages at startup
	auto download new messages
	leave messages on server
	Delete when deleted or moved from my inbox (feature wich doesn't work.. moved
messages are still on server.. but that's knowned bug)


these settings are exactly the same than the other pop accounts and I don't see
anything wrong. Now all is well working, but I have all my messages from one of
my accounts (and only one, I repeat to be sure...) in dubble.
1) we ignore Bryan's comment
2)
Mozilla can't cause a BSOD (Blue Screen of Death) because Mozilla doesn't
install additional device drivers. (winnt/2k/xp)
The problem is in this case your USB modem driver.

you got this (AFAIK):
Mozilla use the standard unix mbox format for mails. 
One file for the mails and another (.msf) for read state and downloaded messages
state etc.
This .msf trashed because the system crashed while this file was open.

Mozilla lost the informations which message is already downloaded and you got
each message again in your inbox.

The last question which decides if this bug is valid :
Do you download messages every x minutes or only at startup ?
(Reporter)

Comment 4

16 years ago
Hi
1) I know that Mozilla didn't cause the crash... I just put all asked in the
forms to try to help... I'm not a devlopper butit takes no time to me to put all
data requested.
2) ok for msf file, that's what I supposed... a spoilt file. thx
3) At startup and every each min.
4) either if it is not a Mozilla failure, put a xxx.msf.back could be safer, no?
You can't use a backup .msf since you could loose mails if the .msf doesn't match
the mail file. It's safer to regenerate the .msf file.

since you check mail every x minutes the is a good reason why this file is open.
It's a valid bug if you don't check the mails and mozilla doesn't close the open
file.

I know it sucks if you must delete x messages but we can't do anything if the
system crashes while Mozilla writes to an file... -> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.