Keychain password storage broken for Blackboard sites

RESOLVED WONTFIX

Status

Camino Graveyard
General
RESOLVED WONTFIX
16 years ago
15 years ago

People

(Reporter: flip@skidmore.edu, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino1.5
PowerPC
Mac OS X

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021108 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021108 Chimera/0.6+

On Blackboard 5 (college content management, http://www.blackboard.com) login
pages the 'password' field isn't properly detected as a candidate for keychain
storage.

Reproducible: Always

Steps to Reproduce:
1. Go to http://bboard.skidmore.edu (or perhaps http://www.blackboard.com)
2. Go to the 'login' page
3. Attempt login (any usernam will do... but if you need to really test storage
or retrieval i'd be happy to set up a user for you. just email me)
4. There is no step 4

Actual Results:  
login as expected, but password not saved (or even dialog box notifying of
keychain storage)

Expected Results:  
keychain dialogbox / password storage

May be similar to bugs 174498 and 178561. Appears that the login dialog / script
is part of some screwy frame stuff (sorry i'm not a html guru...).

Comment 1

16 years ago
chalk.uchicago.edu is also a blackboard site, I get prompted to store the
information, and the user name is stored, but it will not store the password
(the username is stored without any problem).  After a quick glance at the html
I think that it is because the page contains a javascript that creates a md5
hash of the entered password.

function validate_form(form) {

    var passwd_enc = calcMD5(form.password.value);
    var final_to_encode = passwd_enc + form.one_time_token.value
    form.encoded_pw.value = calcMD5(final_to_encode);
    form.password.value = "";

 return true; 

If the keychain is manually changed to have the correct password in it (by
opening the keychain) it will enter the password in the form, but then the form
treats the password is invalid.

MAK

Comment 2

16 years ago
->pinkerton
Assignee: saari → pinkerton
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

16 years ago
Target Milestone: --- → Chimera1.1
(Assignee)

Comment 3

15 years ago
well, if they clear it out before we get a crack at it, i'm not sure what we can
do about it. WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.