Closed Bug 1812248 Opened 1 year ago Closed 1 year ago

Folder URLs with non-ASCII characters break about:3pane

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 111
defect

Tracking

(thunderbird_esr102 unaffected)

RESOLVED FIXED
111 Branch
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Thunderbird gives this error "Uncaught DOMException: String contains an invalid character" when attempting to create the folder list, because it uses btoa to create element IDs, and btoa doesn't like non-ASCII characters.

Version: unspecified → Thunderbird 111
Duplicate of this bug: 1811720

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/fb766d4bae29
Fix broken folder tree by converting folder URLs to byte strings. r=#thunderbird-reviewers,john.bieling

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: