Closed Bug 1812353 Opened 1 year ago Closed 1 year ago

WebGPU: standard features and limits not yet conforming to spec.

Categories

(Core :: Graphics: WebGPU, defect, P1)

defect

Tracking

()

RESOLVED FIXED
116 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox114 --- disabled
firefox115 --- disabled
firefox116 --- fixed

People

(Reporter: ErichDonGubler, Assigned: jgilbert)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Blocks: webgpu-cts
No longer blocks: webgpu-cts
Regressed by: webgpu-cts

The severity field is not set for this bug.
:jimb, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jimb)
Severity: -- → S3
Flags: needinfo?(jimb)
Priority: -- → P3
Attached image image.png
Attached image image.png

I wish I had known this was important, I would have done it 27 days ago! :)
If this is important, this should not be P3, it should be P1.

Priority: P3 → P1
Assignee: nobody → jgilbert
Duplicate of this bug: 1830998
Blocks: 1828123
  • Add validation for requested features and devices for
    adapter.requestDevice().
  • Promote webgl's AutoAssertCast to mfbt/Casting.h/LazyAssertedCast.
See Also: → 1836179

(In reply to Kelsey Gilbert [:jgilbert] from comment #5)

I wish I had known this was important, I would have done it 27 days ago! :)
If this is important, this should not be P3, it should be P1.

Yes - this was my bad.

Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8352bc23343d
Update GPUSupportedLimits in webgpu.webidl. r=webgpu-reviewers,webidl,saschanaz,jimb,emilio,smaug

Backed out for causing causing build bustages in Adapter.cpp.

Flags: needinfo?(jgilbert)
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5ed1439037c4
Update GPUSupportedLimits in webgpu.webidl. r=webgpu-reviewers,webidl,saschanaz,jimb,emilio,smaug
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 116 Branch
Flags: needinfo?(jgilbert)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: