name change: "compress mail folder" -> ?, auto run this function

VERIFIED WONTFIX

Status

MailNews Core
Database
--
enhancement
VERIFIED WONTFIX
16 years ago
10 years ago

People

(Reporter: ingmar2005, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.1) Gecko/20020826

The name "compress folder" made me think the mails would be compressed with a
function like ZIP GZ etc., but only the unshown mails (which I had deleted long
time ago) are deleted out of the file.
I know this function was already in Netscape, but I think it could be changed.

Also this function should be standard on (If I delete a mail in Mozilla, it
should also deleted on my disk)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
There are reasons why you need an additional "compress".
You have a 100MB inbox and you delete one message mozilla must rewrite the
complete file if you want a auto-delete.
This would make Mail very slow. (-> wontfix)

You can enable auto-compressing (if it saves x kb):
edit\preferences\Offline&dis Space\[] Compact Folders ...

and the name in my menu is not "compress" it's "compact".
Which name you suggest for such kind of function ?

without a good suggestion i will close this as wontfix
(Assignee)

Comment 2

16 years ago
It's "compact" for exactly that reason. If there's a problem with the de-AT
localization, you'd need to file a bug on the localization.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
verified Wontfix
compact excatly describes this function.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

16 years ago
My mail should only use the disk space which is needed.
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Comment 5

16 years ago
won't fix. You could argue that auto-compact ought to be on by default, and I'd
agree with that. But we're not going to change our disk format for the reason
Matti described, plus we're using the berkeley mailbox standard format - which
makes interoperability easier.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX
mid-air :-)

i agree that auto-compact should be default enabled (is there already a RFE ?)

this bug is very clear wontfix because there is no way to do this with mbox 
(and it would be stupid to switch to another format)

Please reopen this bug only if you have a VERY good reason
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

16 years ago
I didn't knew that the mail is saved in a standard format.
You are right, I am wrong.
Leave it as it is, but please tell the user of this feature (default on, or
maybe in help "saving disk space"). 

I will do it.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.