yourfreedvds.com - sidebar displayed too wide

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
P3
minor
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: HammerJoe, Unassigned)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021118
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021118

On the left side there are three choices and on the right side it display the
result of those choices.
In Mozilla the left side takes 3/4 of the screen where it should be just 1/4.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
The left side should be much smaller.
(Reporter)

Comment 1

15 years ago
It should be noted that Opera7 and IE display this page the same way and from
the layout of that page I assume Mozilla displays it incorrectly.

Comment 2

15 years ago
Works perfectly well on Linux cvs 200211121.

Reported can you do a screen dump to show us what you are seeing wrong
about the page mentioned  

Comment 3

15 years ago
are you logged in for this ? Perhaps you get a different page from people who
aren't logged in so it's hard to see the problem.
Can you attach a reduced testcase ?
(Reporter)

Comment 4

15 years ago
Isn't this weird.
I just opened the page and indeed it now displays perfectly.
But if I click refresh the problem surfaces again.

So try go into the page, it should display correctly and then refresh the page.

Comment 5

15 years ago
Nope, even with a reload/refresh it works just fine
for me on Linux. Maybe an Windows/XP specific problem ?
Can you provide a screenshot pls.

Comment 6

15 years ago
on second load i saw the same bug with a current trunk cvs, linux.

On third load the page was OK again and I can't repro the bug right now, even if
i delete cache and cookies;

Comment 7

15 years ago
I am not seeing the reported kind of problem on my Mozilla version [1]. Instead
if I go over the left side help links the background shading is "expanded" over
the white area. I'll attach two figs to show this.

[1] Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016
(Reporter)

Comment 8

15 years ago
I will post a screenshot later when I get home, I suppose I just have to use 
the Create attachment link???

Anyway, obviously there are some issues with this page which creates different 
behaviour with some versions, so there is indeed bugs.
Anyone can verify the code of that page to see if it's the page or the 
browser??

Comment 9

15 years ago
Created attachment 107097 [details]
Display OK

Note the red circulated are and compare this to error.png attached separately.

Comment 10

15 years ago
Created attachment 107098 [details]
After hovering over the help links

Compare the red circulated area to one in attachment 107097 [details]
(Reporter)

Comment 11

15 years ago
Created attachment 107112 [details]
Screenshot

Here is the screenshot of the display problem with this page.

Comment 12

15 years ago
Confirming Hammer Joe's screenshot. Looks the same on MacOS X 20030212 build.

There's a fair amount of invalid HTML, but nothing that Quirks mode shouldn't be
able to handle.
Assignee: asa → table
Severity: major → minor
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout: Tables
Ever confirmed: true
Keywords: qawanted
OS: Windows XP → All
QA Contact: asa → madhur
Hardware: PC → All
Summary: Page is not displayed correctly → yourfreedvds.com - sidebar displayed too wide

Comment 13

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.3) Gecko/20030310

Don't see this in 1.3 WIN32.  Is this still a problem?

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 14

14 years ago
Confirmed on moz 2003071814, although the blue part of the page was just too
wide, there were no extending bits like in the screenshots.

After a refresh, all is well.

Comment 15

14 years ago
Same as in #14 with 2003082705.

I played with reload, and it gave quite randomly wides or normals (mostly in
series of 5 or so).

When I saved the page (complete), I couldn't get the local copy wide. Tried
saving both wide and normal pages. Beats me. The page uses php, so perhaps it's
got something to do with that.

Comment 16

14 years ago
Created attachment 131974 [details]
Different on refresh Win 2k
Mozilla 1.5
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030916

Used Mozilla 1.5 Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20030916
And IE 6.0.2.2800.1106
Displayed page on both and Tiled Horizontally. Took screen grab. Looks far
better than previous screen shots  out by about a tiny abount Vs IE.

Comment 17

14 years ago
Comment on attachment 131974 [details]
Different on refresh Win 2k
Mozilla 1.5
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030916

The page is almost identicle to IE 6.0 intialy on refresh the blue section
fills almost 3/4 page. HTML of both is identicle I file diffed them.
Attachment #131974 - Attachment description: Verified to be almost identicle to IE6.0 → Different on refresh Win 2k Mozilla 1.5 Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030916

Comment 18

14 years ago
Created attachment 135473 [details]
Testcase

The page is very bad coded, the widths are all wrong (in some parts the widths
of td's add 748px and the main table is 660px) and i assume that is why mozilla
is acting very weird, this testcase is the smallest i can make without
affecting the bug, i found some interesting  stuff
If you delete any of the meta tags the page appears to work ok
I commented several styles, and the bug appears but if i delete the commented
styles the page works ok
If I delete any of the scripts left the page seems to work ok
If I delete any of the images left the page seems to work ok
If i delete this code <table width="100%"></table> in the middle of the page
the page works ok
If i delete this <div class="sidebarItem" >Hints</div> the page works ok
Im on windows xp pro service pack 1 using Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.5) Gecko/20031007

Comment 19

14 years ago
OS: W2k
Tested with: Mozilla nightly build [Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.7a) Gecko/20031219], Firebird 0.7 [Mozilla/5.0 (Windows; U; Windows
NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7].

1) Using the original page, I got the original problem (left side bar changing
size) to reproduce on Firebird, but not on Mozilla (see versions above).
2) Saving copy of the page to local disk hide the bug. I couldn't get the bug
reappear with local copy on neither browser.
3) Putting the local copy to web didn't help either; located under my home pages
on remote server it works fine. What I noticed is that _during render_ the left
side bar sometimes was incorrectly wide, but set back to correct format when
rendering proceeded.
4) I cannot reproduce the problem with the testcase given on #18.

With this information, I fear this might be some timing bug when comes up with
certain type of strangely broken web pages.

Random sidenote: code of the page doesn't seem to stay same. However, in my
investigation I was unable to see any correlation between page code change and
bug reappearence. Here are the changing lines, anyway:

line 141:
+ <div onmouseout="sBGC(this,0);" onmouseover="sBGC(this,1);"
class="sidebarItem"><nobr><b><a
href="http://www.yourfreedvds.com/newhelp.php">New User Help</a></b></nobr></div>
- <div onmouseout="sBGC(this,0);" onmouseover="sBGC(this,1);"
class="sidebarItem" style="background-color: rgb(216, 221, 238);"><nobr><b><a
href="http://www.yourfreedvds.com/newhelp.php">New User Help</a></b></nobr></div>
+ <div onmouseout="sBGC(this,0);" onmouseover="sBGC(this,1);"
class="sidebarItem"><nobr><b><a
href="http://www.yourfreedvds.com/memberhelp.php">Member Help</a></b></nobr></div>
- <div onmouseout="sBGC(this,0);" onmouseover="sBGC(this,1);"
class="sidebarItem" style="background-color: rgb(255, 255, 255);"><nobr><b><a
href="http://www.yourfreedvds.com/memberhelp.php">Member Help</a></b></nobr></div>
+ <div onmouseout="sBGC(this,0);" onmouseover="sBGC(this,1);"
class="sidebarItem"><b><a
href="http://www.yourfreedvds.com/hints.php">Hints</a></b></div>
- <div onmouseout="sBGC(this,0);" onmouseover="sBGC(this,1);"
class="sidebarItem" style="background-color: rgb(216, 221, 238);"><b><a
href="http://www.yourfreedvds.com/hints.php">Hints</a></b></div>

Updated

14 years ago
Keywords: qawanted → testcase

Comment 20

14 years ago
the site, and the testcase both
WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Comment 21

8 years ago
marking wfm based on comment 20
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.