Change from 'testcase' keyword to 'testcase' flag

RESOLVED DUPLICATE of bug 303614

Status

()

RESOLVED DUPLICATE of bug 303614
16 years ago
5 years ago

People

(Reporter: ian, Assigned: myk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I want to change from a 'testcase' keyword to a 'testcase' flag, so that it is
possible to request testcases from people.

All bugs with the 'testcase' keyword should change to the 'testcase+' flag.

The 'testcase?' flag would be a request for one (clarifying the use of the
'qawanted' keyword), and 'testcase-' would mean the bug has no need for a
testcase, for QA Contacts who want to keep track of that.
(Reporter)

Comment 1

16 years ago
The 'testcase' flag and its description are all set up, but disabled. (This, due
to Bugzilla bug 181239, causes the "flags" header to appear on all bmo bugs.)
When the existing 'testcase' keyword data is moved over to use the flag, we can
enable it.
(Assignee)

Comment 2

16 years ago
A basic data migration could probably be done with an "INSERT INTO SELECT"
statement, but this wouldn't give us flag creation date or setter.  For that
we'd have to first look up the keyword in the bugs activity table to find out
when it was set, at which point it makes sense to write a Perl script to do the
migration.

The other issue to resolve is what to do about the bugs activity table.  Should
it reflect the setting of the flag, and when/who?
(Reporter)

Comment 3

16 years ago
Will removing the keyword remove the activity log of adding that keyword? If
not, I wouldn't worry about the log for the flag.
(Reporter)

Comment 4

16 years ago
->myk since I've done my bit (the flag exists)
Assignee: ian → myk

Comment 5

14 years ago
Is there any reason besides bugspam for me not to just do this with a mass change?

Comment 6

14 years ago
If you do a mass change, could you avoid making a comment? (Or do some people
consider that to be useful?)

I like the idea by the way.

Comment 7

13 years ago
We are already using testcase[?+-] to track requests for testcases to be created and checked into whatever test suite the product/component maintains. See bug 303614. Can we dupe this one forward and work from there?

Comment 8

13 years ago
Resolving as a dupe of 303614 because that bug states that the flag has already been created and just needs to be added to more components/products.

*** This bug has been marked as a duplicate of 303614 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Component: Bugzilla: Keywords & Components → Administration
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.