XML tree is displayed with message "This XML file does not appear to have any style information associated with it"

RESOLVED INVALID

Status

()

Core
XSLT
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Devoti Paolo, Assigned: peterv)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021119
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021119

At provided url is displayed XML tree instead of style handled content.
May be just an evangelize matter since it works with IE6

Reproducible: Always

Steps to Reproduce:
1.open http://www.devpride.com/Universita/default.htm


Actual Results:  
XML tree is displayed

Expected Results:  
style should be applied to xml content
to XSLT for triage, but it looks like the site's usage of XSLT is just
completely broken....
Assignee: asa → peterv
Component: Browser-General → XSLT
OS: Windows 98 → All
QA Contact: asa → keith
Hardware: PC → All
(Assignee)

Comment 2

16 years ago
<xsl:stylesheet xmlns:xsl="uri:xsl">

That namespace is completely wrong, it needs to be
http://www.w3.org/1999/XSL/Transform (see
http://www.mozilla.org/projects/xslt/index.html#faq). Reporter: can we close
this or should we reassign to evangelism?
> <?xml:stylesheet href="index.xsl" type="text/xsl"?>

and linking to stylesheets are done using using a  xml-stylesheet  processing
instruction (not xml:stylesheet). I.e. it should look like this:

<?xml-stylesheet href="index.xsl" type="text/xsl"?>
(Reporter)

Comment 4

16 years ago
If nothing belongs to mozilla is appropriate to close this as invalid.
INVALID per reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.