www.weia.po.opole.pl - Technical University of Opole uses proprietary JavaScript (document.layers and document.all) [LAYERS]

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
16 years ago
4 years ago

People

(Reporter: marcoos, Assigned: piskozub)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021119 Phoenix/0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021119 Phoenix/0.4

Technical University of Opole, Poland (Politechnika Opolska) - Department of
Electrical Engineering and Automatic Control (Wydzial Elektrotechniki i
Automatyki) uses proprietary JavaScript to create a navigation menu. This works
only in MSIE and Netscape 4.

Reproducible: Always

Steps to Reproduce:
1. Go to www.weia.po.opole.pl (but don't click English - international version
does not have any JavaScript). You'll be redirected to
www.weia.po.opole.pl/n2/default.asp
2. Under the image with "Wydzial Elektrotechniki i Automatyki" text, you should
see an empty bar (part of a JPEG file)
3. This is the place, where the menu should appear. (in HTML it's <span
id="holder">...

Actual Results:  
That field is empty. You won't see anything there.

Expected Results:  
Display the navigation menu as NN4 and MSIE do. But it won't.

The webmaster (webmaster@weia.po.opole.pl) has just been contacted by me, I've
sent him a working replacement for that script with some HTML corrections, too,
and information about how to deal with it.

The corrected version of that page can be found at
http://www.marcoos.zwm.punkt.pl/weia 
(until the webmaster updates the original page). Maybe this will help Mozilla
users wanting to read some information from that page (which is important for
people who study at PO/WEiA, as I do ;))

Now waiting for answer from the webmaster.
(Assignee)

Comment 1

16 years ago
Confirming and accepting. 
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3
(Assignee)

Updated

16 years ago
Summary: Technical University of Opole uses proprietary JavaScript (document.layers and document.all) → www.weia.po.opole.pl - Technical University of Opole uses proprietary JavaScript (document.layers and document.all) [LAYERS]
Target Milestone: --- → Nov
(Assignee)

Comment 2

16 years ago
Marek, good job. The script used originally on the page "yx_menu G2" is written
so bad that it is nor worth correcting. 

In case I need it in future, Marek used instead "ULTIMATE DROPDOWN MENU VERSION
3.5 by Brothercake"
(Reporter)

Comment 3

16 years ago
The webmaster didn't answer my e-mail, but installed a new version of the menu
script (not the one I used, though :)

At the moment, WEiA is using the menu-script from http://www.milonic.co.uk/menu 
and seems to work perfectly in Mozilla, Netscape and MSIE, and not-so-bad in Opera.

I've sent another email to WEiA's webmaster saying "Thank you for updating your
website to work in all browsers".

Note: my version will soon now removed from zwm.punkt.pl, because I need some
free space.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

16 years ago
Thanks again.
Status: RESOLVED → VERIFIED

Comment 5

16 years ago
tech evang june 2003 reorg
Component: Europe: Central → Polish
Target Milestone: Nov → ---
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.