embedded objects with 100% width and height are invisible

RESOLVED DUPLICATE of bug 131065

Status

Camino Graveyard
Plug-ins
RESOLVED DUPLICATE of bug 131065
15 years ago
14 years ago

People

(Reporter: mark burdett, Assigned: Simon Fraser)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021119 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021119 Chimera/0.6+

embedded objects with 100% width and height are invisible, for example:

<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" width="100%"
height="100%" codebase="http://www.apple.com/qtactivex/qtplugin.cab">
<param name="SRC" value="http://www.indybay.org/uploads/chevron2sm.mov">
<param name="AUTOPLAY" value="true">
<param name="CONTROLLER" value="true">
<embed src="http://www.indybay.org/uploads/chevron2sm.mov" controller="true"
autoplay="true"
cache="true" targetcache="true" width="100%" height="100%" 
pluginspage="http://www.apple.com/quicktime/download/">
</embed></object>

Reproducible: Always

Steps to Reproduce:
1. create an <object><embed></embed></object>
2. specify width="100%" and height="100%" for both elements.
Actual Results:  
object is rendered invisible

Expected Results:  
one would expect the object to fill out the view frame (or otherwise use all
available space).

Comment 1

15 years ago
Works in trunk.

Comment 2

15 years ago
Since this works on the trunk, I think this is bug 131065. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
handing over to karnaze for verification of dupe of bug 131065
Assignee: peterlubczynski → karnaze

Comment 4

15 years ago
karanze doesn't have a Mac and this is in the Chimera tree which is based off
the 1.0 branch so that's why it doesn't have the fix to bug 131065.

simon, do you want to port the patch?
Assignee: karnaze → sfraser
Camino is on the trunk now, so this is a non-issue.

*** This bug has been marked as a duplicate of 131065 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.