Div within cell misrendered

RESOLVED DUPLICATE of bug 144542

Status

()

Core
Layout: Tables
P3
normal
RESOLVED DUPLICATE of bug 144542
16 years ago
15 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

1.09 KB, text/html
Details
(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016

A table cell with div's set inside are not rendered.  They extend beyond the
cell boundaries into other text.

Reproducible: Always

Steps to Reproduce:
1. Go to the above website
2. Look at news section below headlines
3.

Actual Results:  
div extends into right-side table cell when it should be completely inside the
middle cell.

Expected Results:  
render the news section properly
(Reporter)

Comment 1

16 years ago
This also happens with the latest nightly build (11/20/02)
To tables; looks like the padding/margin of those divs are not being taken into
account?
Assignee: asa → table
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout: Tables
Ever confirmed: true
OS: Windows XP → All
QA Contact: asa → amar
Hardware: PC → All

Comment 3

16 years ago
Created attachment 107125 [details]
testcase

it looks we render it as required by the spec. The div is 100% of its
containing block and then it is shifted by the margin, it has to overlap.

in other words:

<div style=" width=200px;border: solid 10px;">
<div style=" width=100px;border: solid 10px;">
foo
</div>
</div>

In an standard compliant browser the innerdiv will overlap the outer div.
I believe this bug is a) invalid
b) techevangelism

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 144542 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.