enable "Move to Folder" UI in junk mail dialog

VERIFIED FIXED in mozilla1.3beta

Status

defect
--
major
VERIFIED FIXED
17 years ago
11 years ago

People

(Reporter: dmose, Assigned: sspitzer)

Tracking

(Blocks 1 bug)

Trunk
mozilla1.3beta
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Turn on the UI that allows users to have their junk mail automagically moved to
a folder.
Reporter

Updated

17 years ago
Depends on: 181397

Comment 1

17 years ago
Now, I've heard that there is some work that needs to be done to make this
happen ... but, the TURNING it on part is done in
--document.getElementById("moveOnSpam").disabled = false;-- from
junkmail.js correct?

The only problems that I've heard of are the moving of Junk Mail to a
non-existent directory.  Any others ??? 

Comment 2

17 years ago
*** Bug 181887 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
It may be good to test this out with a pref (not enable the UI) before actually
enabling the UI.
*** Bug 182001 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
Is 181397 really the only reason why the UI isn't enabled? If so, couldn't this
be "worked around" for now by simply defaulting to Trash and allowing the user
to specify another folder if desired?

Perhaps this part of the UI could be enabled with a hidden pref until 181397 is
fixed?

Comment 6

17 years ago
I agree, Joe.  Why can't the default to "TRASH" be enabled ... and we could at
least test out the auto-move functionality ... 

Comment 7

17 years ago
Before turning this on: There's small UI bug few lines below the moveOnSpam
disabled line that causes only one of the junk mail destination radio buttons to
be enabled at a time. Probably easiest to fix this together with enabling.

Current code:
document.getElementById("moveTargetMode0").disabled = !enabled || (choice == 1);
[..]
document.getElementById("moveTargetMode1").disabled = !enabled || (choice == 0);

New code:
document.getElementById("moveTargetMode0").disabled = !enabled;
[..]
document.getElementById("moveTargetMode1").disabled = !enabled;

Comment 8

17 years ago
Ive altered and tested the junkmail.js changes ... it works fine for me on POP
accounts (creates mail folder "JUNK", not "JUNK MAIL" as expected) ... 

Some improvements:
1)  JUNK folder needs to have its own graphic (not a standard folder)
2)  RUN JUNK MAIL CONTROLS ON SELECTED MESSAGES should also include the MOVE
actions.
Sit tight, this is top on my list.  Andrew / Udo, thanks for the testing.  More
soon.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.3beta

Comment 10

17 years ago
*** Bug 185664 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
*** Bug 187343 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
This patch enables the disabled Junk UI ("Move to Folder") and fixes the JS bug
that prevents the selection of a folder other than "Junk Mail" (comment #7 from
Udo).

To apply this patch to an already built Mozilla you need to extract
messages.jar to get at content/messenger/junkMail.js. Once the patch has been
applied, repackage messages.jar (maintain the paths inside), move it back into
place in your Mozilla install, and restart Mozilla.

This /does not/ fix the bug that has caused this feature to be disabled (e.g.
it does not create the "Junk Mail" folder for you). You need to manually create
the folder or specify an already existing folder.

Comment 13

17 years ago
Oops. Small correction to the previous text - "messenger.jar," not "messages.jar."
Does it work for IMAP too? I just heard a rumor that it didn't, but I'd love to
be proven wrong.

Comment 15

17 years ago
for imap, you may have to create the junk folder yourself by hand, since Seth is
still working on the code that creates the folder automatically on demand. but
once the folder is created, the move to folder stuff works fine for imap; I've
been using it for months now.
taking, I'm working on all this.
Assignee: dmose → sspitzer
Status: ASSIGNED → NEW
fixed, checked in with the fix for #181397
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 18

17 years ago
Is there some documentation available for this?

I manually created the Junk Mail folder, enabled the feature, specified messages
as Junk, run "Run Junk Mail Controls ...", but cannot seem to get any action out
of it (no logging either ...)

Comment 19

17 years ago
ok, so for the checked in version the folder is named just Junk, but still see
no log messages or other activity ...

Comment 20

17 years ago
Works dandy for me on two independent installs.

If the feature is not working for you you should probably file a new defect.

Comment 21

17 years ago
I'm glad to hear that it works for you.

The problem is that it does not work here, and before filing a bug saying

"Does not work for me"

which would be answered by somebody like you saying

"Works here. Closing"

I'm trying to understand what I'm doing wrong and for that I would like to see
some steps/documentation on how to trigger the spam filter.

Comment 22

17 years ago
Manually running 'Run Junk Mail Controls on Select Messages' does not appear to
move messages for me.  However, new incoming mail that is flagged as junk IS
being moved to the Junk folder.

My question is what was the intended behavior of this feature?  Is it supposed
to move messages while manually running the junk filter or not?

Comment 23

17 years ago
Scott,

So you just set the junk mail flag for certain messages, than delete the
messages (from the Inbox), and you see messages moved into your Junk folder on
the next download new messages?

Comment 24

17 years ago
Yes.  You have to 'train' the filter to recognize spam before you can expect to
see anything auto marked as spam.  I would say (based on my non-scientific
observations) that you need to mark at least 50 to 100 messages as spam to get
the filter to start working.  For me it has consistently gotten better the more
I have used it, and it now catches 95% of the spam I get.

I have only been using the 'auto move to Junk folder' for 4 days now, but it
does work for me.

Comment 25

17 years ago
thx. maybe I did not mark enough messages as spam (yet :). I will keep going ...
>Manually running 'Run Junk Mail Controls on Select Messages' does not appear to
>move messages for me.  However, new incoming mail that is flagged as junk IS
>being moved to the Junk folder.
>
>My question is what was the intended behavior of this feature?  Is it supposed
>to move messages while manually running the junk filter or not?

that's a bug.  I plan to make it so when you manually run the controls, we move
the messages (assuming you've got it configured to do this.)

this feature is still evolving.  but feel free to log bugs on issues you see in
nightly builds.

scott, the bug for your issue is #180029

Comment 28

17 years ago
I have seen messages being moved to Junk. Thanks for the comments Scott.

Comment 29

17 years ago
[OT]
This bug is jet another major milestone in Mozilla's evolution! Thank you for
providing us with such an excellent browser to use (ahem, "test"). :-D
[/OT]

PS. RE Comment #26: Could you post the bug number for moving junk mail when
"manually running junk mail controls"?

Comment 30

17 years ago
>> running junk mail controls manually should respect preferences
>> bug #180029

Comment 31

17 years ago
OK using jan15 commercial trunk: win98, mac OS 10.2, linux rh8.0
Generally enabled and functioning. Not all scenarios tested.  Will log issues
found with this portion of the junk mail feature as separate bug reports.
Marking this verified.
Status: RESOLVED → VERIFIED

Comment 32

17 years ago
After having initial success with this feature, the last 2 mornings I have had
20+ messages marked a junk, but not moved to the junk folder.

When a single message is pulled from the server at a time and marked as junk, it
is successfully moved to the junk folder.  The problem I am seeing only happens
when I check my mail for the first time in the morning, and receive many
messages that are marked as junk, but not auto moved.  I have seen this same
behavior on both the 2003011505 and 2003011605 builds.

Should I re-open this bug, or file a new one.  This bug was tracking 'enable the
feature', should I open a new one to track bugs on the feature itself?

Comment 33

17 years ago
Sorry, just read Laurel's commment #31.  I will open a new bug on this.

Comment 34

17 years ago
*** Bug 191575 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.