tab content blanked out on close of tab to the left of selected tab

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
11 years ago

People

(Reporter: iainmccoy, Assigned: jag+mozilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

If I use the "Close Tab" item of the right click menu of any tab to the left of
the currently selected tab, the content of the current tab is blanked out until
I switch to a different tab, then back to the tab that was selected at the start
of the process.

Reproducible: Always

Steps to Reproduce:
1. create two or more tabs
2. Select the rightmost tab
3. right-click on any tab other than the rightmost tab
4. select "close tab"

Actual Results:  
the current tab's content is greyed out - the entire area is filled with a grey
colour. I suspect this grey is the "default" colour for the theme, assuming it
exists.

Expected Results:  
Continued to display the content of the current frame

Occurs in both "modern" and "classic" themes; started occuring after upgrading
from 1.0 (as packaged by debian) to the 1.2 beta tarball installer, with all
packages included.

Mailnews is not installed.
(Reporter)

Comment 1

16 years ago
The actual result isn't quite as I reported here. It is setting the content of
the current tab to be the content of the tab one to the right of the current
tab; when the tab closed is the rightmost tab, it is blank because the "content"
of a nonexistent tab is blank. Sorry about that.
(Reporter)

Comment 2

16 years ago
This bug appears to be fixed in the Mozilla 1.2 release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.