Closed Bug 1814091 Opened 1 year ago Closed 1 year ago

WebGPU CTS fails with `navigator.gpu.getPreferredCanvasFormat is not a function`

Categories

(Core :: Graphics: WebGPU, defect, P3)

defect

Tracking

()

RESOLVED FIXED
113 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox111 --- unaffected
firefox112 --- unaffected
firefox113 --- fixed

People

(Reporter: ErichDonGubler, Assigned: jgilbert)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Honestly, there's not a better description I could give that the title, ATM. Will edit accordingly once detail are better understood.

Repro link: https://gpuweb.github.io/cts/standalone/?runnow=1&q=webgpu%3Aweb_platform%2Ccanvas%2CgetPreferredCanvasFormat%3A*

No longer blocks: webgpu-cts
Regressed by: webgpu-cts

The severity field is not set for this bug.
:jimb, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jimb)
Severity: -- → S3
Priority: -- → P3
Duplicate of this bug: 1785576
Duplicate of this bug: 1806660
Duplicate of this bug: 1825186
Assignee: nobody → jgilbert
Flags: needinfo?(jimb)
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/721a7c52f1ab
Move CanvasContext.getPreferredFormat to GPU.getPreferredCanvasFormat. r=gfx-reviewers,jimb,emilio

Backed out for causing wpt failures in cts.https.html

  • Backout link
  • Push with failures
  • Failure Log
  • Failure line: TEST-UNEXPECTED-PASS | /_mozilla/webgpu/chunked/51/cts.https.html?q=webgpu:web_platform,canvas,getPreferredCanvasFormat:value:* | : - expected FAIL
Flags: needinfo?(jgilbert)
Blocks: 1826677
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/75bf730d9bca
Move CanvasContext.getPreferredFormat to GPU.getPreferredCanvasFormat. r=gfx-reviewers,jimb,emilio
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 113 Branch
No longer blocks: 1826677
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: