Mail folder with special character in name looks empty while it is not

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Marc-Etienne VARGENAU, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; fr-FR; rv:1.0.0) Gecko/20020611
Build Identifier: http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.2b/mozilla-macosX-1.2b.smi.bin

When a mail folder name begins with a bullet (special MAC OS character), 
when displaying the content of the folder, it semmes empty while is is not.
Renaming the folder to a "normal" name allows to see the content again.


Reproducible: Always

Steps to Reproduce:
1. create a mail folder "foo"
2. put some messages in it
3. display the folder : you see the messages
4. rename the folder to "<bullet> foo"
5. display the folder : it seems empty
6. rename the folder to "foo"
7. display the folder : you see the messages again
Actual Results:  
The folder seems empty.


Expected Results:  
The content of the folder should be visible.
And this has what to do with the browser?  ;)
Assignee: asa → sspitzer
Component: Browser-General → Mail Window Front End
Product: Browser → MailNews
QA Contact: asa → olgam
Version: Trunk → other

Updated

16 years ago
QA Contact: olgam → esther

Comment 2

16 years ago
Seems to WorkForMe using FizzillaCFM/2002112208 and a uwimapd server on Solaris
9. What server are you using, Marc-Etienne?

Comment 3

16 years ago
Is your mail account POP or IMAP?
How do I get the special Mac OS charater you are using?
We had known bugs where some characters were considered illegal characters in
folder names that caused the folder to be rebuild with a randomly generated name
leaving the old folder there looking empty.  This was fixed months ago, does
this happen with a more current build?

Comment 4

16 years ago
I see we have a tracking bug for folder names with illegal characters, if the
reporter still sees this problem with the latest build or tells me how to get
the special macOSX charater so I can test this myself then this should be listed
in the tracking bug.  Tracking Bug124287

Comment 5

16 years ago
(esther, the bullet character can be typed using option+8.)

Comment 6

15 years ago
Thanks Greg for the info.
Reporter, using the MacOX and the latest commercial builds I do not see the
problem you report.  I then took one of our latest release commercial builds and
still did not see the problem.  I then took a mozilla build from the link you
provided and still did not see the problem.  The user agent you list is not the
same user agent I get when  taking the build you provided in the link. Your user
agent looks like a French version.  I tested this with POP and IMAP.
cc'ing marina in international qa 

Comment 7

15 years ago
i tried this on MacOSX with 11-20-1.0 build and i didn't have a problem while
creating, renaming, copying to another server, accessing when i used a bullet
char. Marc-Etienne, could you please see whether you still have problem with
newest build? 

Comment 8

15 years ago
Maybe the Sun OS referred to by his user agent is significant. Maybe he renamed
the folder using his Mac, but then had problems accessing the folder using
Mozilla on Sun OS.
(Reporter)

Comment 9

15 years ago
Hello, I am the initial submitter of the bug.
The bug occurs on MAC OS X.
It is 1.2 beta, build id 2002101612

It has nothing to do with Solaris: I just happened to submit
the bug with Solaris.

The mail folders came from Netscape 4.5 on Mac OS 8.1.
I transfered them on my new Mac with Mac OS X 10.2 (Jaguar).

On my FRENCH keyboard, the bulllet "•" is obtained with
shift alt ';'

Regards.

Comment 10

15 years ago
Marc-Etienne, when you say <The mail folders came from Netscape 4.5 on Mac OS 8.1.
I transfered them on my new Mac with Mac OS X 10.2 (Jaguar)> you mean these were
POP, Local folders and you've copied them and then had a display problem or the
folders were created with Commmunicator 4.5 on the IMAP server and then opened
on MacOSX? Thanks.
(Reporter)

Comment 11

15 years ago
Some more information.

1) I use POP accounts.

2) I managed to reproduce the bug without reference to the fact that
mail folders were transferred from one Macintosh to another.

I created a new user on my Macintosh.
With this account, I created a new mail account (POP) at my ISP.
I sent myself 2 mail messages.

So there are 2 messages in Inbox
I create a new folder named "<bullet> toto <bullet>"
I move one message from Inbox to folder.
I select the folder: the message is visible
I transfer the second message in the folder: the folder appears empty
After that, I try to rename the folder: I get an error message 
and I cannot raname the folder.

Comment 12

15 years ago
Marc-Etienne, i repeated your steps using 2002112608 build and didn't experience
any probelm in accessing the folder, neither renaming it. What build are you using?
Esther, do you see the problem with the recent builds?
(Reporter)

Comment 13

15 years ago
As stated in my comment from 2002-11-27, it is build 2002101612.

Comment 14

15 years ago
Marc-Etienne, please retest using a current nightly build.

Comment 15

15 years ago
No response from reporter in 2.5 months. Resolving WFM per comment 12.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.