Bookmark Toolbar Folder does not stay where it is moved

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
trivial
RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: Ryuichi KUBUKI, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 

On 20021119, WinXP

After moving Bookmark Toolbar Folder to the bottom of
folders (I mean, if root has the folders A, B, C, changing
it to B, C, A, in this case A is Bookmark Toolbar Folder),
 closing Bookmark Manager and reopening it,
Bookmark Toolbar Folder comes back on the top of all folders.

Reproducible: Always

Steps to Reproduce:
1. Open Bookmark Manager
2. Cut and paste Bookmark Toolbar Folder to the bottom of
folders
3. Close Bookmark Manager
4. Reopen Bookmark Manager

Actual Results:  
Bookmark Toolbar Folder comes back to the top again

Expected Results:  
Bookmark Toolbar Folder should retain its position.

View is unsorted. If it's default that Bookmark Toolbar Folder
is always upper to other bookmark folders, I hope it changes.

Comment 1

16 years ago
The BTF is always at the top. I don't know why this is so, but that's the way it
has always been. BTW you can't cut&paste the BTF, because the BTF can't be deleted.

Suggesting WONTFIX. Does anyone disagree?

Updated

16 years ago
Severity: normal → minor
OS: Windows XP → All
Summary: Bookmark Toolbar Folder comes always on the top of Bookmark Manager → Bookmark Toolbar Folder can't be moved from the top position in Bookmarks Manager

Comment 2

16 years ago
I don't even think it's WONTFIX; it's INVALID if you ask me. As I understand it
the BTF is at the top because it is different from all the others in that it IS
the BTF, which, as Simon has noted cannot be deleted...

Comment 3

16 years ago
If it's supposed to be on top all the time, it shouldn't be movable in the first
place.

This could be turned into a bug report about the folder being movable when it
shouldn't.

Comment 4

16 years ago
->trivial (if not won'tfix)
Severity: minor → trivial
(Reporter)

Comment 5

16 years ago
Then I request another different icon for BTF to indicate it's a special folder
to users. When moving into Phoenix first, I couldn't tell it from other ordinary
folders :) I was annoyed by it and removed it from bookmarks.html manually since
I didn't use it much, but later Phoenix looked freezed due to lack of it, so I
was forced not to remove it.
Severity: trivial → enhancement
Summary: Bookmark Toolbar Folder can't be moved from the top position in Bookmarks Manager → Bookmark Toolbar Folder is movable
(Reporter)

Comment 6

16 years ago
Then I request another different icon for BTF to indicate it's a special folder
to users. When moving into Phoenix first, I couldn't tell it from other ordinary
folders :) I was annoyed by it and removed it from bookmarks.html manually since
I didn't use it much, but later Phoenix looked freezed due to lack of it, so I
was forced not to remove it.
Summary: Bookmark Toolbar Folder is movable → Bookmark Toolbar Folder is movable (and needs its own icon)
(Reporter)

Updated

16 years ago
Summary: Bookmark Toolbar Folder is movable (and needs its own icon) → Bookmark Toolbar Folder shouldn't be movable (and needs its own icon)

Comment 7

16 years ago
Cleaning-up unconfirmed bugs :)

For me, it now beeps when I try to cut the Bookmarks Toolbar Folder, but I can
still move it. It doesn't really need its own icon though as it should be fairly
evident upon looking at it that the only two sites in that folder happen to be
the ones on the bookmarks toolbar when you run Phoenix the first time or in a
new profile.

-->New, Trivial
-->removing "(and needs its own icon)" from summary.
Severity: enhancement → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Bookmark Toolbar Folder shouldn't be movable (and needs its own icon) → Bookmark Toolbar Folder shouldn't be movable

Comment 8

16 years ago
Might want to change the summary (title) of this bug :). It says the exact
opposite of this bug's purpose. I've noticed this bug too on Phoenix 0.5.

Comment 9

15 years ago
Someone change the title of this bug!!!!

-> Bookmark Toolbar Folder should be movable

and not "Bookmark Toolbar Folder shouldn't be movable"

Comment 10

15 years ago
The name is correct - the BTF is supposed to be at the top of the stack but at
present it can be "moved" but then it returns as soon as the Bookmarks Manager
is reopened (or more accurately, when it is closed). We do not want the BTF to
be anywhere but at the top at all times, hence the name of this bug. The
original reporter made the honest mistake of misinterpreting buggy behaviour as
intended behaviour (being able to apparently move the folder) and then noted the
fact that this didn't occur on a permanent basis.

Comment 11

15 years ago
I agree with the reporter that the best way to fix this bug is to make moving
the bookmarks toolbar stick, not to make it unmovable.

Someone mentioned changing the icon for the personal toolbar folder.  That's bug
47595, "Special folders like 'Personal Toolbar Folder' should have different icons".

Comment 12

15 years ago
Regarding #10, why is it so bad to allow the user to position the BTF whereever
they want?
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 14

15 years ago
Don't know why Colin didn't mention this, but...

WFM. I can carry out the reporter's steps and the BTF stays where I put it.
Additionally, I can stick it in other folders and copy/paste it. Finally I can
export/import the bookmarks and the BTF behaves correctly. 

Possibly related to bug 173875.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030728 Mozilla
Firebird/0.6.1

Comment 15

15 years ago
So it is moveable and now also stays there.
-> wontfix?
The original bug was that the BTF didn't stay where it was if moved.  It does now.

Resolving WORKSFORME based on the last couple of comments, changing summary back
to original bug repor issue.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Summary: Bookmark Toolbar Folder shouldn't be movable → Bookmark Toolbar Folder does not stay where it is moved
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.