Content of form lost when hitting back-button

RESOLVED DUPLICATE of bug 140697

Status

()

Core
Document Navigation
RESOLVED DUPLICATE of bug 140697
16 years ago
10 years ago

People

(Reporter: Steinar Kaarø, Assigned: John Keiser (jkeiser))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.1) Gecko/20020826

After using http://wgate.bibsys.no/search/gen?lang=E to search, the content of
the form is lost when hitting the back-button.
This happens if the page has hidden parameters placed before the input fields,
and the form is in or is surrounding a table. If the hidden parameters are
placed after the input fields, it works. Also if all table tags are removed, it
works.
Opera and Explorer works.


Reproducible: Always

Steps to Reproduce:
1.http://wgate.bibsys.no/search/gen?lang=E
2.Type "mozilla" in the "Free text" field.
3.Hit "Search"
4.Hit "Back"
5."mozilla" has disappeared.
Actual Results:  
Content of form has disappeared.

Expected Results:  
Showed the previous form content, in order to easily modify the the search.
1.0.1 is very old.  Is this a problem with current trunk builds?
(Reporter)

Comment 2

16 years ago
1.2b has the problem as well.

Comment 3

16 years ago
dupe of bug 179330 ?
Seeing this behavior as well, even though that particular bug has been fixed on
Nov 21. I'm using Moz 2002112208 on XP Pro SP1

Comment 4

16 years ago
the given URL does not have a search form.
(Reporter)

Comment 5

16 years ago
Perfect timing. The site is down for maintenance until Nov. 25 0700 CET.

Comment 6

16 years ago
Confirmed using Mozilla 12/23 and Phoenix 12/27 (both trunk nightlies) on WinXP.
 A testcase would be nice.
Status: UNCONFIRMED → NEW
Ever confirmed: true
form restoration. over to jkeiser. 
Assignee: radha → jkeiser

Comment 8

16 years ago
Created attachment 112246 [details]
testcase

it looks like the hidden <input> before the <tr> is causing the problem here.

Comment 9

16 years ago
dupe of "Misplaced form element and hidden input element(s) break form value
restoration when pressing Back"

*** This bug has been marked as a duplicate of 140697 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.