CSS postion: absolute not correctly aligning div's when Sidebar is visible

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Joe Stump, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021122
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021122

In the page http://www.joestump.net/pages/news.php?THEME=slate the page aligns
correctly and generally looks great when the Sidebar is collapsed. However, when
the Sidebar is visible the div ID #links does not align correctly as it should.
It appears that, for some odd reason, the CSS argument left: is not being
readjusted for that ID. What makes it more perplexing is that div ID #short
aligns correctly after opening the Sidebar. Refreshing the page does not fix it.

Reproducible: Always

Steps to Reproduce:
1. Make sure your Sidebar is NOT visible
2. Go to http://www.joestump.net/pages/news.php?THEME=slate
3. Make your Sidebar visible

Actual Results:  
The alignment for div ID #links is not adjusted to work within the new window size.

Expected Results:  
The div ID #links should adjust correctly to the new window size. Currently left
is set to a given percent. Thus if the window is changed size (because of
enabling the Sidebar) the position defined in my CSS should be adjusted correctly.

I just installed the latest nightly build and it failed as well. The same
problem was experienced in Moz under OS 10.2.2 as well.
I can't seem to reproduce this problem... The links div is always positioned
around the middle of the browser window (which makes sense with left:55%). 
Linux build 2002-11-08-04 here.

Of course in the last 3 minutes the value went from 55% to 570px to 610 px,
which really makes debugging sort of difficult....
(Reporter)

Comment 2

15 years ago
After doing some more investigation I found the following ...

1.) Making the window smaller would also cause the anomoly
2.) IE rendered it incorrectly as well (in the exact same manner)
3.) Making it absolute with a px value fixed it.

Just got your message about me changing it in the middle of debugging. Sorry
about that. It appears everything is working fine and I misunderstood how the
alignment worked with the position tag. Sorry for wasting your time and thanks
for the quick response.
Ah.  Yeah, the overlap was caused by %-sizing the offset but having the stuff
before it be a percentage + the size of some text...

Marking invalid, per comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.