change xpcom so that callers do not need to know that a class is a service

VERIFIED DUPLICATE of bug 181513

Status

()

Core
XPCOM
--
enhancement
VERIFIED DUPLICATE of bug 181513
16 years ago
16 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

({arch})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
People want to believe that being a service is an implementation detail, but the
fact is that it isn't. There is no way for something to find out if the
implementation of a contract is a service and therefore "must" be accessed by
using getService() instead of createInstance().  Someone suggested using
nsIClassInfo, but the catch 22 is that to use classinfo you need a class which
means either calling getService() or createInstance() -- and in today's world if
you call the wrong one, bad things will happen.

I'll attach a discussion, some ideas and other stuff later, for the time being I
just need this bug so I can reference it elsewhere.

*** This bug has been marked as a duplicate of 181513 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v (timeless sucks)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.