Delete calendar: need remove from list without deleting file; need confirmation or undelete

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: gekacheka, Assigned: Mike Potter)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016, 2002112213-cal

Delete calendar is a destructive operation that isn't always desired.

(a) It should be possible to remove a calendar from a user's calendar list
without deleting the calendar file.  Example:  alpha team shares
/share/alpha/GroupMeetings.ics through the local file server.  If a user moves
from alpha team to a different team, beta, the user needs to be able to remove
the alpha calendar (and add the beta calendar) without deleting the alpha
calendar file.

(b) Deleting a calendar should require confirmation, in case user does a 'mouso'
and clicks 'delete calendar' instead of 'edit calendar' or some other nearby
menu item.


Reproducible: Always

Steps to Reproduce:
1. Use "New calendar" to create a new calendar, say /temp/test1.ics
2. click-right on the new calendar in the calendar list, and "Delete Calendar" 


Actual Results:  
Test1 was removed from calendar list.
File /temp/test1.ics was deleted.

Expected Results:  
Expected option whether or not to delete underlying file.

Expected confirmation dialog on this infrequent yet destructive operation.
(alternative:  a recycle bin for calendars so user can undelete by pulling it
out of recycle bin.)


One way to deal with this might be with checkboxes:

   Remove Test1 from calendar list?
   [ ] Also delete file /temp/test1.ics 
                          
                                                      {OK}   {Cancel}
(Assignee)

Comment 1

16 years ago
Fixed in CVS.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

16 years ago
Ok, I see you've added separate confirm buttons for 
  [Delete Calendar] [Delete Calendar and File] [Cancel]
This looks like a good approach, but the wording is a bit confusing -- it sounds
like the choice is between deleting one or two things, and it is not clear what
the difference is between those two things.

I think this would be better worded as 
  [Remove Calendar], [Remove Calendar and Delete its File], [Cancel] 

So removing and deleting are more clearly not the same kind of operation, and it
is clear the file is the calendar file.

Hope this helps!

The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.