Add a feature to search for duplicate bookmarks.

RESOLVED WONTFIX

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
19 years ago
6 years ago

People

(Reporter: Kevin Berkheiser, Unassigned)

Tracking

({helpwanted})

Trunk
Future
x86
Windows NT
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox][Extension Fodder])

(Reporter)

Description

19 years ago
I would like the bookmark manager to have the capability to find duplicate
bookmards and delete or move them to a duplicate bookmark folder.
(Reporter)

Updated

19 years ago
Depends on: 11417
(Reporter)

Updated

19 years ago
No longer depends on: 11417
(Reporter)

Updated

19 years ago
Blocks: 11417

Updated

19 years ago
Assignee: waterson → rjc

Updated

19 years ago
Priority: P3 → P5
Target Milestone: M20

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → LATER

Comment 1

19 years ago
Later.

Comment 2

18 years ago
Related: bug 10198, "[RFE]Warn user if adding an existing bookmark."

Reopening from resolved/later to future milestone, and adding the helpwanted 
keyword.
Status: RESOLVED → REOPENED
Keywords: helpwanted
Resolution: LATER → ---
Target Milestone: M20 → Future

Updated

17 years ago
Assignee: rjc → nobody
Status: REOPENED → NEW

Comment 3

17 years ago
Future, reassigning...

Comment 4

16 years ago
lovely idea, hope this will be finished tomorrow ? *duck*

Comment 5

16 years ago
Yuk. This is why I dislike Tom (my network QA teammate) being stuck w/ RDF...

This is either a dupe of bug 10198, or it needs to be re-written as the RDF bug
that that bookmarks feature would depend on...
Assignee: nobody → ben
Component: RDF → Bookmarks
QA Contact: tever → claudius
(Reporter)

Comment 6

16 years ago
I don't have a problem changing the component to RDF, but I am seeing two
related but different bugs.

bug 10198 seems to be intended have Mozilla search the existing bookmarks during
an add to make sure the bookmark does not already exist.  If so, I would expect
Mozilla to update the existing bookmark (title etc. may have changed) and notify
the user.

This bug, was intended to have the bookmark manager provide an option to search
for duplicate bookmarks.  

If bug 10198 were implemnted, and the Mozilla installer were updated to weed out
duplicate bookmarks, then this bug would not need to be fixed because there
could never be a duplicate bookmark.

Please feel free to assign this bug and rewrite it in whichever way you see fit.
 If you let me know what you think needs to be done, I can spend the time
re-writing the bug.

Thanks
Summary: Add a feature to find duplicate bookmarks. → [RFE]Add a feature to search for duplicate bookmarks.

Comment 7

16 years ago
On the bookmarks management, let me jump in here.  I keep very extensive
bookmarks.  
  
I disagree about preventing duplicate bookmarks. Duplicate bookmarks should not
be prevented. I often manage bookmarks into areas of interest and there is
sometimes overlap.  

However, at the present time there is no way to find bookmarks with the search
function.  You can search, and you get a list in a separate window.  You cannot
then find those bookmarks where they exist in the manage bookmarks window.  So
you cannot delet them or drag them into folders.   

It would be good to be able to search for bookmarks by keyword in the manage
bookmarks window, and be able to find again. This would allow finding and
managing duplicates and related issues.  This cannot be done now.  

As it is now, the bookmark management is between non-existant and grimly difficult. 

Updated

16 years ago
Summary: [RFE]Add a feature to search for duplicate bookmarks. → Add a feature to search for duplicate bookmarks.

Comment 8

14 years ago
Just a note of agreement with previous poster (Steve, comment 7). I know that this comment doesn't 
wholly belong with this bug, so I'll try to keep my comments on-topic.

It would be nice to be able to search for duplicate bookmarks with the option of deleting at will. I don't 
think auto-updating and replacement of previous bookmarks is desirable, though perhaps a dialog 
explaining that "A duplicate bookmark was found in x | y | z folder. Would you like to update the 
bookmark or create a new one?" would offer clear options.
Product: Browser → Seamonkey

Comment 9

14 years ago
(In reply to comment #7)
> On the bookmarks management, let me jump in here.  I keep very extensive
> bookmarks.  
>   ...

I agree with the whole of this comment. I would like also to have the
ability to replace a duplicate, with an alias, perhaps with a different
title. Each substantive bookmark would need an ID ...

If I have a section of my bookmarks devoted to Perl (which I do) and
a section on Poetry, I would like links to pages concerning Perl poetry
to be in the Perl section with aliases in the Poetry section.

Removing duplicates, particularly without confirmation, would be a 
bad idea. Of course duplicates in the
same section, or adjacent duplicates are not needed: In the latter case
it would be OK for Firefox to refuse to create them, in the former I think
that it would be OK for them to highlighted to be handled manually.

Comment 10

12 years ago
bump this because it would be great to see this in ff2. showing duplicates and what folders they're in if they're in a folder so they can be found... :)

Comment 11

12 years ago
This bug should block bug 10198 as that one uses this feature.

https://addons.mozilla.org/firefox/1553/ detects duplicate bookmarks for Firefox.
Assignee: bugs → nobody
QA Contact: claudius → bookmarks

Comment 12

6 years ago
1) Now you can't make duplicate bookmark (see Bug 789468)
2) Firefox duplicate bookmarks finder from http://bookmarkdd.mozdev.org/ after modding install.rdf partially working in SeaMonkey, so if somebody still interested in this bug it's worth asking that add-on developer to add complete SeaMonkey support
I propose closing this as invalid, any other thoughts?
Priority: P5 → --
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA?]

Comment 13

6 years ago
I'd say this is probably extension fodder but I'm not completely sure.

Updated

6 years ago
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA?] → [2012 Fall Equinox][CLOSEME 2012-11-01 WONTFIX?][Extension Fodder]

Comment 14

6 years ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: 19 years ago6 years ago
Resolution: --- → WONTFIX
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 WONTFIX?][Extension Fodder] → [2012 Fall Equinox][Extension Fodder]
You need to log in before you can comment on or make changes to this bug.