Closed Bug 1815584 Opened 1 year ago Closed 11 months ago

The message thread sometimes doesn't update when a new message is received

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 111

Tracking

(thunderbird_esr102 unaffected, thunderbird111 wontfix, thunderbird112 affected)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird111 --- wontfix
thunderbird112 --- affected

People

(Reporter: aleca, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, steps-wanted, Whiteboard: [Supernova3p])

This happens randomly and I can't reproduce it consistently.
But this is a potential STR:

  • Select the INBOX
  • Select a message in the thread pane
  • "Receive a new message"

The message thread doesn't show the new message and it only appears after changing folder selection.

Sometimes it works, sometimes it doesn't. Even waiting a bit longer doesn't make the message appear.

Whiteboard: [Supernova]

I am not able to reproduce this. But then, I made only two tests, one with messages sorted date descending and one date ascending.

Barry, Calum, are you able to reproduce with daily?

Flags: needinfo?(calum.mackay)
Flags: needinfo?(bsfinkel)

I really know little about this bug, so I really am not sure how to test it. And I am no longer running the daily build.

Flags: needinfo?(bsfinkel)

I'm not running the current Daily; I'm still on 110.0a1 2023-01-14 (MacOS 13.1). I've been waiting for a supernova feature parity announcement before updating.

I can't reproduce the issue with that build.

Sometimes it looks like something similar has happened: no email is visible, but if I scroll down it appears. i.e. it had appeared but was not visible in my current scroll (which was at the end).

Flags: needinfo?(calum.mackay)

(In reply to Calum Mackay from comment #3)

Sometimes it looks like something similar has happened: no email is visible, but if I scroll down it appears. i.e. it had appeared but was not visible in my current scroll (which was at the end).

In that case, perhaps related to another message list bug report?

Flags: needinfo?(alessandro)

Nicolas, can you reproduce this behavior?

Flags: needinfo?(mozilla.nicolasweb)

In reply to Wayne Mery (:wsmwk) from comment #5)

Nicolas, can you reproduce this behavior?

Yes, I do. I noticed that sometimes I need to move to another folder and come back to get message tread updated.
I'll have a look at it monday or tuesday, to try to better identify it, and tell you here. (So I keep the NI open)(

This is still happening, and I'm tracking this alongside Geoff.
It's intermittent and it doesn't always happen, but sometimes the message thread goes out of sync with the folder pane.

We need to investigate the cause and ensure a proper data flow so all the panes are in sync.

Flags: needinfo?(mozilla.nicolasweb)
Flags: needinfo?(alessandro)
See Also: → 1816812
Severity: -- → S3
Priority: -- → P2

Scanned all the bug reports. So far, no other reports of this issue. And none in the beta forum afaict.

Blocks: 1821988

Aleca, Still seeing this?

Flags: needinfo?(alessandro)

I haven't seen this in a few weeks, so let's close this tentatively.

Status: NEW → RESOLVED
Closed: 11 months ago
Flags: needinfo?(alessandro)
Resolution: --- → WORKSFORME
Whiteboard: [Supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.