cannot reset/undo italics.

RESOLVED WORKSFORME

Status

SeaMonkey
Composer
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Suresh, Unassigned)

Tracking

({helpwanted, qawanted})

Trunk
x86
Windows 2000
helpwanted, qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
steps.

1. http://news.com.com/2100-1001-966926.html?tag=fd_top load this link in a browser.
2. Select a bunch of text from two paragraphs. I selected
"In two specific segments, Intel-based servers and Unix servers, IBM and Dell
also gained.

In Intel servers, where IBM remains the third-ranked seller"
3. Ctrl + C to copy the text.
4. File | Send page to bring mail compose page
5. Paste the text _above_ the link that appears in msg body.
6. Again select the just pasted content. Hit Ctrl + I to make it italic.
7. Place the cursor at the end of the content. In this case after "seller". Hit
enter.
8. Type some more stuff using the keyboard. it appears in Italic by default. Try
to undo/reset the Italics. I cannot rest it.

Reproducible: ALWAYS

Build: 11-21-02 trunk build on win2k.

Comment 1

16 years ago
Sigh ... bugzilla lost my comments the first time.  Trying again ...

Here's a much easier way to reproduce a problem that may or may not be the same
problem suresh is reporting -- I'm not sure.

1. Get an editor window with a blank line followed by a link.
2. Copy the specified text from the news.com url, and paste it into the blank line.
3. Press the I (italic) button and type some stuff.  Notice that the I button is
not depressed even though new text appears in italic.
4. Now try to get out of italic mode.  Pressing I again doesn't work;
discontinue text style doesn't work either.

Suresh: is this the same problem you were reporting?
Charley: shouldn't I appear pressed, since we're in italic mode, even though the
selection is collapsed?  It's confusing not being able to see what mode we're in.
Joe: Is this an edit rules issue at all, or more a UI issue?
Akkana: I can't reproduce your test case.

Comment 3

16 years ago
Argh.  Now I can't either.  There must have been something special about the
br-and-link that I pasted before, and now I can't find a combination that does
it.  If I see it again, I'll note the steps.

Comment 4

16 years ago
reassign
Assignee: syd → composer
Keywords: helpwanted, qawanted
Product: Browser → Seamonkey

Comment 5

13 years ago
the steps in comment 0 are WORKSFORME

Suresh: can you still reproduce this problem with a recent build (1.7 or 1.8b)?

Comment 6

13 years ago
resolving WORKFSORME
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.