"Sending failed" error - need better message

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: mozilla-bugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I am trying to send a message and I keep getting a "Send Message Error" telling
me that:

> Sending of message failed.
> 
> Please verify that your Mail & Newsgroups account settings are correct and try
again.

First, this message is *completely* uninformative. It does not give any
information on what exactly failed, at what stage of sending the message, etc.

Second, whatever failed is a bug - I've succesfully sent several emails in this
Mozilla session (including from the very same account) and I do not see anything
different for this particular messages. The SMTP server is working OK, the
settings are still correct ("localhost", Never SSL, no auth)...

BuildID 2002112018 compiled and running on Red Hat Linux 8.0
(Reporter)

Comment 1

16 years ago
Ah, when trying to "Send Later" the message instead, I am still getting an error:

> Unable to save your message in order to send it later.
>
> Please verify that your Mail & Newsgroups account settings are correct and try
again.

So this is a Composition issue, not an SMTP one.

"Save as draft" -> same deal:

> Unable to save your message as draft.
>
> Please verify that your Mail & Newsgroups account settings are correct and try
again.

And I still have no idea what it is that it's complaining about!

It appears there is no way for me to preserve the message, so marking dataloss
(I can still copy&paste the body, but it's not exaclty the same and having the
actual message, with all the proper headers, attachments, etc).
Assignee: mscott → ducarroz
Component: Networking: SMTP → Composition
Keywords: dataloss
Summary: SMTP error out of nowhere; need better message → "Sending failed" error out of nowhere; need better message
(Reporter)

Comment 2

16 years ago
OK. the error message was caused by bug 181127. I still wish, the error message
was better and in particular explained what "stage" of message sending failed
(e.g. if retrieving one of the attachments fails, the error message should have
the word "attachment" in it, etc). Leaving this bug open as an RFE for a better
error messages.
Severity: major → enhancement
Depends on: 181127
Keywords: dataloss
OS: Linux → All
Hardware: PC → All
Summary: "Sending failed" error out of nowhere; need better message → "Sending failed" error - need better message
Product: MailNews → Core

Comment 3

13 years ago
duplicate of bug 120278?
Assignee: ducarroz → nobody
QA Contact: esther

Comment 4

11 years ago
Nope, they different. In current 2.x version of TB there no such problem it report error correctly more verbose(like timeout or error connecting). Marking as WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.