Downloaded with appended php extension with .zip

RESOLVED DUPLICATE of bug 146781

Status

RESOLVED DUPLICATE of bug 146781
16 years ago
5 years ago

People

(Reporter: ali_akbani, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

When downloaded with download manager the zip file got saved as xxx.zip.php The
size of files matched but the extension was wrong. Worked fine with IE

Reproducible: Always

Steps to Reproduce:
1.Click on the Nuzzly 3.02 link
2.Choose save as
3.OK

Actual Results:  
Saved file with .php instead of .zip extension

Expected Results:  
not appended the php extension

Updated

16 years ago
Whiteboard: DUPEME

Comment 1

16 years ago
I can reproduce this with 2002112204 on Win2k.
Not sure if this is a duplicate of some other file type bug, though.

Shouldn't this bug belong to 'File Handling' component?

(Mohammed, your build is a bit old for reporting bugs. Many things happen during
3 months...)

Comment 2

16 years ago
Is this bug a duplicate of bug 120327 (again ?) or of bug 144334 ?

Comment 3

16 years ago
Or may be dup of bug 170239, which is quite identical to this one: 
When php serves an application/octet-stream file, it gets a .php extension...

Comment 4

16 years ago
Reproduced on WinXP SP1 with 20021122.

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 146781 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
I think this is a dupe of bug 65827 , not 146781, since the ".PHP"
filename-extension is being appended to the end rather than being substituted.
Product: Browser → Seamonkey

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.