Status

SeaMonkey
General
--
critical
VERIFIED DUPLICATE of bug 90471
15 years ago
12 years ago

People

(Reporter: Tethys, Assigned: rubydoo123)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TB14286730Y, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

The page loads, and a few seconds later the browser crashes. Because of the
small font, the first time I went to the page, I was holding down Ctrl, about
to hit + to enlarge the font. The second time, I was actually resizing the font
at the time of the crash. The third time I just let the page load, and did
nothing. It still crashed. This was with mozilla-1.2a. I downloadded mozilla-1.2b,
and tried again, but got the same results.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL listed above
2. Wait a couple of seconds
3. Crash!




Talkback IDs:
 TB14286443Y  (with 1.2a)
 TB14286503Z  (with 1.2a)
 TB14286632W  (with 1.2a)
 TB14286730Y  (with 1.2b)

Comment 1

15 years ago
wfm 2002111811 windows XP

Comment 2

15 years ago
It does not crash for me.  Instead, after a few seconds I hear some tasty metal
rock.

Reviewing the HTML source I see ...

<embed 
  src="darkavenger.swf" 
  hidden="true" 
  width="77" 
  height="57" 
  autostart="true" 
  loop="1" 
  starttime="00:02" 
  volume="80"
>

... and perhaps this is causing asa@mozilla.org's system to crash.

Comment 3

15 years ago
Tethys, can you upgrade to Flash 6 ? Do you still crash ?
http://www.macromedia.com/software/flashplayer/special/beta/
Assignee: asa → beppe
Component: Browser-General → Plug-ins
Keywords: crash, stackwanted
QA Contact: asa → shrir
Whiteboard: TB14286730Y

Comment 4

15 years ago
wfm using build 2002112108 on Linux + Flash 6.0r60.
(Reporter)

Comment 5

15 years ago
Yep, upgrading to flash 6.0 r61 has at least fixed the crashing problem
(even if I don't hear the music). Not sure whether to mark this as resolved
or not. Is it considered a bug that a fault plugin can bring down the whole
browser? I'd say yes, and they should be suitable sandboxed to prevent this,
but I don't know how feasible it is...

Comment 6

15 years ago
Tethys, this is bug 156493.
I'm not closing this bug report because the real bug wasn't determined, waiting
for stack trace.
However, when crashing with Flash 5, were you running any sound player while
loading this page, were you running Mozilla remotely ?
(Reporter)

Comment 7

15 years ago
Yes, xmms was open (and configured to use the esound output plugin).
Was I running remotely? No, Mozilla was displaying on the local X
server, if that's what you're asking.

Comment 8

15 years ago
Tethys, I believe your crash was bug 58339, fixed in Flash 6 (and mentioned in
Flash 6 release notes).
(Reporter)

Comment 9

15 years ago
Nope. It's definitely not a dup of bug 58339. This one caused a browser
crash -- 58339 only blocked until the sound device was available.

Comment 10

15 years ago
this is bug 90471 -- flash plugin playing while hidden causes a crash

*** This bug has been marked as a duplicate of 90471 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: Plug-ins → Browser-General
Resolution: --- → DUPLICATE

Comment 11

15 years ago
flash plugin playing AUDIO while hidden causes a crash
(Assignee)

Comment 12

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.