Closed Bug 181619 Opened 18 years ago Closed 16 years ago

caret disappears going up from table in table into another table

Categories

(Core :: DOM: Selection, defect)

defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: hurtta+mozilla2, Assigned: mjudge)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016


Seems that i geot cursor disappear on composer test page.
Is anyone other sene this?

Reproducible: Sometimes

Steps to Reproduce:
1.Select
          Debug-> Composer (with test page)
2. Press pageDown until you are end of text at point "he hides at well."
3. Press cursor up until you are end of box "big cell 1" (five times does
   that to me)
4. Press cursor up

Actual Results:  
cursor disappers

Expected Results:  
Cursor should have gone to previous line

At least i do have not fixured yet to wher epoint to cursor goes.
Moziilla do NOT freeze. If I press cursor down, it appears again.

If I press cursor left instead, it appears to end of box "cell 9"
instead.

I think that that same point is where it should appear when I press
cursor up (instead of disappearing.)
On 

Mozilla 1.3a

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021123

that test page looks empty, so I can not test it on there.

-->selection
I see this in my debug macho build
To see it in Composer, you may need to open this page in the browser first:
  mozilla/editor/ui/composer/content/EditorInitPage.html

(unable to open the test page is covered by bug 186050)

The weird thing is that if you actually type some text when the caret isn't
blinking, it appears between the two tables (which is kinda what is expected I
guess?).
Assignee: syd → mjudge
Component: Editor: Composer → Selection
Keywords: nsbeta1
OS: Linux → All
QA Contact: sujay → pmac
Hardware: PC → All
Summary: Composer test page misbehauviour? → caret disappears going up from table in table into another table
adt: nsbeta1-
Keywords: nsbeta1nsbeta1-
Blocks: caretnav
works for me with Mozilla 1.4.2 and Mozilla 1.7
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.