Closed Bug 1816197 Opened 2 years ago Closed 2 years ago

Show a success message with some stats on what got imported in the new MigrationWizard

Categories

(Firefox :: Migration, task, P1)

task

Tracking

()

RESOLVED FIXED
112 Branch
Tracking Status
firefox112 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

We want to add some infrastructure so that we can report how many bookmarks and logins got imported. We'll probably want to add more down the line. I've also added "history" in here, because we happen to have that value lying around. Down the line, we'll change the string to say how many days back worth of history was imported, but for now, the quantity of visits will do.

I've also gone ahead and added a new progress callback to the MigratorBase.migrate method, because the old observer mechanism was pretty clumsy to work with.

Severity: -- → S3
Priority: -- → P1
Duplicate of this bug: 1805983
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f1622e804031
Part 1: Make MigratorBase.migrate resolve only after migration has completed. r=NeilDeakin
https://hg.mozilla.org/integration/autoland/rev/c9d72f2246e4
Part 2: Add an optional callback to MigratorBase.migrate to get migration updates. r=NeilDeakin,fluent-reviewers,flod
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 112 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: