If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

tiled, animated background image causes severe performance degradation

VERIFIED DUPLICATE of bug 94828

Status

()

Firefox
Build Config
VERIFIED DUPLICATE of bug 94828
15 years ago
15 years ago

People

(Reporter: Ben Andrews, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4

In the page at http://www.geocities.com/rfwdg/Links.html, the tiled animated GIF
that serves as the background image causes a massive performance degradation,
making even navigating away from the page a difficult chore.  While this is
admittedly horrid web design - I would be perfectly happy if Mozilla rendered
this background as the first frame only as a workaround - other browsers seem to
handle it fine.  

Reproducible: Always

Steps to Reproduce:
1.  Visit http://www.geocities.com/rfwdg/Links.html in Phoenix 0.4
Actual Results:  
The web browser's performance degraded severely, causing even moving the mouse
pointer to be difficult.  It did not crash and recovery was possible by
navigating (slowly) to a new page.

Expected Results:  
Mozilla should either have rendered the animated GIF as a single frame (in fact,
since I had the preference set to "One" for frames to show of an animated GIF,
this was the expected behavior) or it should have operated at a normal rate of
speed.

*** This bug has been marked as a duplicate of 94828 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Mass verifying of old bugs.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.