When I open asp page (java script) with text data field, the textdata field don't display (Smarteam)

RESOLVED WORKSFORME

Status

()

Core
Layout
P2
major
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Vaclav Priborsky, Unassigned)

Tracking

Trunk
Other
IRIX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: works on 1.0 branch, not 1.2 branch (or trunk), not an UA issue)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; IRIX IP32; en-US; rv:1.3a) Gecko/20021120 

When I open asp page (java script) with text data field, the textdata fileld
don't display(java script console is blank). If I try this in Netscape Navigator
7.0 or MS Internet Explorer all is ok.
If I try this in Mozilla on Windows NT, text data field don't show.

Reproducible: Always

Steps to Reproduce:
1.Open Mozilla browser on IRIX 6.5
2.type address in location
3.enter the web with text data fields
(Reporter)

Comment 1

15 years ago
Created attachment 107235 [details]
Mozilla error

This Image show mozilla error.
(Reporter)

Comment 2

15 years ago
Created attachment 107236 [details]
Same address with Netscape 7.0

This jpeg display same adress in netscape 7.0

Comment 3

15 years ago
Has it ever worked with any Mozilla version ?
Does it work with Mozilla 1.0.1, which is the version Netscape 7 is based on ?

Otherwise, can you attach a testcase for this frame ? Which application is this
? Is there a demo available on the Web ?

Finally, does it work with your current build 20021120 if you had Netscape 7 in
the user agent field (modifying your user.js or prefs.js), see the FAQ on how to
do this on the Web) ?
OS: other → All
Hardware: Other → All

Comment 4

15 years ago
found the product: http://www.smarteam.com/ but couldn't find documentation,
client requirements or on-line demo.
(Reporter)

Comment 5

15 years ago
This is web portal application to pdm system smarteam from Dassault systemes,
but on the their web isn't demo. I try to public our pdm server to internet.
(Reporter)

Comment 6

15 years ago
The page of server is http://212.71.161.91:8888/smartweb/Pages/Login/Login.asp

username: joe
password:
database: SmDemo
(Reporter)

Updated

15 years ago
OS: All → IRIX
Hardware: All → Other

Comment 7

15 years ago
Created attachment 107361 [details]
Sniffer trace of the HTTP output when clicking on Profile with Mozilla

Comment 8

15 years ago
hard to debug as they deactivated right click, I attached a sniffer trace from
what happens when clicking on Profile with Mozilla 20021123 on Win2k.
However, given the complex code and the high number of JavaScript errors, I
guess this is a bad Mozilla handling issue and it should be moved to Tech
Evangelism.

btw, I set OS as All instead of Irix because this affect Win2k & Linux as well
as Irix.
I'll try to add Netscape 7 to my ua string to see if it solves something.
Summary: When I open asp page (java script) with text data field, the textdata fileld don't display → When I open asp page (java script) with text data field, the textdata field don't display (Smarteam)

Comment 9

15 years ago
I tried setting my ua to Netscape/7.0 but this didn't help so it can actually be
a regression from Mozilla or a code change not properly handled by Smarteam product.

+Keyw: testcase, eventhough there's no reduced testcase, at least we can start
with something.
Assignee: asa → other
Component: Browser-General → Layout
Keywords: testcase
QA Contact: asa → ian

Comment 10

15 years ago
just tested build 1.0.2 20021122 on Win2k and site works fine, I can see the
profile text.
So, there's definitely a difference between 1.0.x branch and 1.2.x branch that's
either a real Mozilla bug or something new/changed in Mozilla's JS code that
Smarteam doesn't handle properly.
Vaclav, can you enable debug mode ? From source, g_DebugLevel = 0 so it
restricts any browser from using view frame source which is annoying.
Whiteboard: works on 1.0 branch, not 1.2 branch (or trunk), not an UA issue
(Reporter)

Comment 11

15 years ago
Now is debuging enable.
(Reporter)

Comment 12

15 years ago
Sorry. Now is debuglevel ok
(Reporter)

Comment 13

15 years ago
Right click is now enable in asp (now is debug level set to 0)
(Reporter)

Comment 14

15 years ago
Right click is now enable in asp (now is debug level set to 1)

Updated

15 years ago
Priority: -- → P2
http://212.71.161.91:8888/smartweb/Pages/Login/Login.asp shows a blank page.  Is
there a page that shows this bug?
Keywords: testcase
Unable to connect to http://212.71.161.91:8888/smartweb/Pages/Login/Login.asp
Unable to connect to http://212.71.161.91/
No response from Reporter.

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.