Mozilla dumps core when invalid args are passed to shell script wrapper

VERIFIED WORKSFORME

Status

Core Graveyard
Tracking
P3
minor
VERIFIED WORKSFORME
18 years ago
a year ago

People

(Reporter: Pat Gunn, Assigned: Steve Lamm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Mozilla dumps core when invalid arguments are passed to the shell
script wrappers. Does not dump core when invalid args are passed to
it directly. 100% reproducible, checked with 6 November 1999 build.
Backtrace is as follows:
(gdb) bt
#0  0x200024e881c in XInternAtom () from /usr/X11R6/lib/libX11.so.6
#1  0x20002048ab0 in gdk_atom_intern (atom_name=0x20001c17cf7 "text/plain",
only_if_exists=0) at gdkproperty.c:46
#2  0x20001bbe138 in nsClipboard::Init (this=0x1201c4350) at
../../../../mozilla/widget/src/gtk/nsClipboard.cpp:184
#3  0x20001bbdcdc in nsClipboard::nsClipboard (this=0x1201c4350) at
../../../../mozilla/widget/src/gtk/nsClipboard.cpp:84
#4  0x20001bf1934 in nsWidgetFactory::CreateInstance (this=0x1201db580,
aOuter=0x0, aIID=@0x12010b880, aResult=0x11ffff848)
    at ../../../../mozilla/widget/src/gtk/nsWidgetFactory.cpp:217
#5  0x2000050da28 in nsComponentManagerImpl::CreateInstance (this=0x120110160,
aClass=@0x11ffff908, aDelegate=0x0, aIID=@0x12010b880,
    aResult=0x11ffff848) at
../../../mozilla/xpcom/components/nsComponentManager.cpp:1261
#6  0x20000521d38 in nsComponentManager::CreateInstance (aClass=@0x11ffff908,
aDelegate=0x0, aIID=@0x12010b880, aResult=0x11ffff848)
    at ../../../mozilla/xpcom/components/nsRepository.cpp:77
#7  0x20000523670 in nsServiceManagerImpl::GetService (this=0x12010f6f0,
aClass=@0x11ffff908, aIID=@0x12010b880, result=0x11ffff918,
    shutdownListener=0x0) at
../../../mozilla/xpcom/components/nsServiceManager.cpp:248
#8  0x200005242b8 in nsServiceManager::GetService (aClass=@0x11ffff908,
aIID=@0x12010b880, result=0x11ffff918, shutdownListener=0x0)
    at ../../../mozilla/xpcom/components/nsServiceManager.cpp:455
#9  0x12000663c in nsService::nsService (this=0x11ffff908, aProgID=0x12000a5b4
"component://netscape/widget/clipboard", aIID=@0x12010b880,
    rv=0x11ffff900) at ../../dist/include/nsIServiceManager.h:302
#10 0x120004fa4 in main (argc=4, argv=0x11ffff988) at
../../../mozilla/xpfe/bootstrap/nsAppRunner.cpp:692

Updated

18 years ago
Assignee: chofmann → slamm

Comment 1

18 years ago
who owns the shell script wrapper? looks like ramiro and slamm
or pass to briano when he gets back..
(Assignee)

Comment 2

18 years ago
Would you give me some examples of what you are doing? I looked at
mozilla-apprunner.sh, it checks the arguments for valid ones.

Comment 3

18 years ago
I can't reproduce this on my Linux/Alpha test builds.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 4

18 years ago
Marking worksforme.

Comment 5

18 years ago
Marking Verified as WorksForMe, this no longer occurs with latest build.  Please 
use latest nightly build from: http://www.mozilla.org/binaries.html and reopen 
bug if is happens again.  Thanks!
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.