Closed Bug 1816593 Opened 1 year ago Closed 1 year ago

Various dialog sizing issues with flexbox emulation

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 111
Unspecified
All
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird111 unaffected)

RESOLVED FIXED
112 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird111 --- unaffected

People

(Reporter: aleca, Assigned: aleca)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [snnot3p])

Attachments

(3 files)

Trying to tackle all the regressions in our dialogs.
Some are tricky since they're a tangle of XUL mess and we should really rebuild them all in HTML, or just drop most of them for subdialogs.

For now, let's try to fix them as much as possible.

Status: NEW → ASSIGNED

I'm having issues in fixing the attendees dialog as the attendees list and "busy" schedule grows without the shrinking when resizing the dialog.
That whole section should be nuked, so the code is not the best.
Emilio, any hint on what is needed to fix that area not resizing with the parent dialog?

Flags: needinfo?(emilio)

Sorry can I get more pointers? Is this the #calendar-event-summary-dialog? Or something else?

#calendar-event-summary-dialog {
  height: 100vh;
}

Makes no sense, since height: 100vh means that if we lay out with a zero-height viewport the element itself will be zero-height. I think removing that should do?

Also, removing:

#calendar-item-summary {
  width: 0;
}

fixes the horizontal sizing issues. You probably want min-width: 0 if at all (I think you don't need that).

And to fix the splitter you want it to only affect one of the two elements, so you probably want resizebefore="sibling" on that splitter between the attendees and the event description.

Flags: needinfo?(emilio) → needinfo?(alessandro)
OS: Unspecified → All
Version: unspecified → Thunderbird 111
Flags: needinfo?(alessandro)
Target Milestone: --- → 112 Branch

Thanks Emilio for the pointers, Richard is taking care of those.

What I was referring to was the calendar-event-dialog-attendees-v2, and specifically the #freebusy-grid which expands on resize but it doesn't shrink, locking the size of the dialog.

You can access that dialog from Calendar Tab > New Event > Invite Attendees.

Flags: needinfo?(emilio)

I don't see that on daily, do I need a local build? What I see is the grid shrinking as needed. If I need a local build... I suspect adding contain: inline-size to #freebusy-grid will help?

Also there's some width="250" in that window that needs changing to style="width: 250px"

Flags: needinfo?(emilio)

Pushed by martin@humanoids.be:
https://hg.mozilla.org/comm-central/rev/923b4c469fd6
Fix wrong sized dialogs due to flexbox emulation. r=Paenglab
https://hg.mozilla.org/comm-central/rev/f5356ea67cc5
Fix wrong sized calendar-summary-dialog and customizeToolbar. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Removing the 111 affected flag since the flexbox emulation is only enabled in daily, so it doesn't affect beta.

Reopening this since we missed some dialogs:

  • Compact folder dialog is too long
  • Attendees dialog doesn't resize properly
  • OpenPGP key manager dialog has the wrong size (probably the richlistbox item is affected as well)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Adding to the list the invitation dialog (triggered from the status bar) opens up completely flat.

The compose toolbar is completely collapsed.
EDIT: Nope, my bad for having the format toolbar hidden.

Attachment #9318305 - Attachment description: Bug 1816593 - Fix wrong sized dialogs due to flexbox emulation - Part 2. r=#thunderbird-front-end-reviewers → Bug 1816593 - Fix wrong sized Compact Folder dialog due to flexbox emulation. r=#thunderbird-front-end-reviewers

Richard and Kai, the OpenPGP dialogs are all sort of messed up due the the flexbox emulation.
The fact that we use those dialogs both as standalone dialog and as SubDialog doesn't help, and it's becoming increasingly difficult to handle.

We have 2 patch forward here:

  • Try to fix as much as possible what we have with bandaids. (Richard, could you take a look?)
  • Kick-off an implementation effort to stop using standalone dialogs for anything openPGP and rely on subdialogs.

I'm leaning towards option 2, since that will allow us a much cleaner and simpler UI.

Flags: needinfo?(richard.marti)
Flags: needinfo?(kaie)

I'm also for option 2. When do we use the stand alone dialogs that aren't possible as subdialogs?

Flags: needinfo?(richard.marti)
Whiteboard: [snnot]

Which release would you like to target, 2023 or 2024 ?
(I'm guessing 2024.)

(In reply to Alessandro Castellani [:aleca] from comment #13)

The fact that we use those dialogs both as standalone dialog and as SubDialog doesn't help, and it's becoming increasingly difficult to handle.

Can you give an example?

  • Kick-off an implementation effort to stop using standalone dialogs for anything openPGP and rely on subdialogs.

Would you want to keep or remove standalone OpenPGP key manager window?
Working on UI re-shuffling means less time available to fix/improve functionality, so I'd appreciate help with that work.

Flags: needinfo?(kaie)

Re the OpenPGP manager, see bug 1731231.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/50d3fd93673a
Fix wrong sized Compact Folder dialog due to flexbox emulation. r=freaktechnik

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Whiteboard: [snnot] → [snnot3p]
Duplicate of this bug: 1796635
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: